Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 600063 - [abrt] crash in openoffice.org-writer-1:3.2.0-12.23.fc13: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
[abrt] crash in openoffice.org-writer-1:3.2.0-12.23.fc13: Process /usr/lib/op...
Status: CLOSED DUPLICATE of bug 598582
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:ab7c3f9e87f954c678d75ff4698...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 17:51 EDT by Andrew Jones
Modified: 2010-06-04 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 01:03:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (251.87 KB, text/plain)
2010-06-03 17:51 EDT, Andrew Jones
no flags Details
OOXML file that causes Open Office 3.2.0 to shut down instantly (81.69 KB, application/octet-stream)
2010-06-03 18:02 EDT, Andrew Jones
no flags Details

  None (edit)
Description Andrew Jones 2010-06-03 17:51:43 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer
component: openoffice.org
crash_function: writerfilter::ooxml::OOXMLFactory::createFastChildContextFromStart
executable: /usr/lib/openoffice.org3/program/swriter.bin
global_uuid: ab7c3f9e87f954c678d75ff4698596933199208a
kernel: 2.6.33.5-112.fc13.i686
package: openoffice.org-writer-1:3.2.0-12.23.fc13
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
File opens OK with my wife's Microsoft Office 2003 and OOXML reader add-on
With Open Office 3.1.1 build 9420 it opens and just displays a blank page.  Presumably it uses Microsoft features not supported by Open Office.  I can live with that
As soon as I open it with version 3.2.0 the whole program shuts down.  100% repeatable.  I find that scary.
This is a 4 day old installation of Fedora 13 and I have not yet built up much confidence in it.  I am having stability problems also with Evolution so if you find you can open this file with the latest version of Open Office I am prepared to believe I have a problem with the OS itself and will re-install.  

How to reproduce
-----
1.Open the attached OOXML file
2.(I can't work out how to attach anything to this ABRT submission so I will reply with the attachment)
3.
Comment 1 Andrew Jones 2010-06-03 17:51:55 EDT
Created attachment 421047 [details]
File: backtrace
Comment 2 Andrew Jones 2010-06-03 18:02:41 EDT
Created attachment 421052 [details]
OOXML file that causes Open Office 3.2.0 to shut down instantly

Couldn't work out how to attach anything to the ABRT submission.  (Maybe an attach button is present below the bottom of my notebook's small screen?)
Comment 3 David Tardon 2010-06-04 01:03:34 EDT

*** This bug has been marked as a duplicate of bug 598582 ***

Note You need to log in before you can comment on or make changes to this bug.