Bug 600145 - Install failure with x86_64 RHEL6.0-20100603.n.0-Server-x86_64-DVD1.iso
Summary: Install failure with x86_64 RHEL6.0-20100603.n.0-Server-x86_64-DVD1.iso
Status: CLOSED DUPLICATE of bug 600225
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 601041
TreeView+ depends on / blocked
 
Reported: 2010-06-04 02:36 UTC by Zachary Amsden
Modified: 2010-06-08 18:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 18:21:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of failure (Retry does not work) (5.56 KB, image/png)
2010-06-04 02:37 UTC, Zachary Amsden
no flags Details
screenshot of yum log (18.68 KB, image/png)
2010-06-04 20:26 UTC, Zachary Amsden
no flags Details
anaconda.log (7.04 KB, application/octet-stream)
2010-06-04 20:30 UTC, Zachary Amsden
no flags Details
program.log (10.90 KB, application/octet-stream)
2010-06-04 20:30 UTC, Zachary Amsden
no flags Details
yum.log (1.45 KB, application/octet-stream)
2010-06-04 20:31 UTC, Zachary Amsden
no flags Details

Description Zachary Amsden 2010-06-04 02:36:13 UTC
Description of problem:

Failed to install on virtual machine

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Spend 4 hours downloading ISO image
2. Attempt to install, wiping out existing installation
3.
  
Actual results:


Expected results:


Additional info:

Guest memory size was 512M, so graphical installer could not be used.

Comment 1 Zachary Amsden 2010-06-04 02:37:40 UTC
Created attachment 421097 [details]
screenshot of failure (Retry does not work)

Comment 3 Chris Lumens 2010-06-04 13:53:30 UTC
Please switch over to tty2, grab /tmp/anaconda.log, and attach it to this bug report.  Thanks.

Comment 4 Zachary Amsden 2010-06-04 20:26:33 UTC
Created attachment 421345 [details]
screenshot of yum log

I checked the full log, it appears the only failure starts with the None/.treeinfo stuff

Comment 5 Zachary Amsden 2010-06-04 20:30:33 UTC
Created attachment 421346 [details]
anaconda.log

Comment 6 Zachary Amsden 2010-06-04 20:30:54 UTC
Created attachment 421347 [details]
program.log

Comment 7 Zachary Amsden 2010-06-04 20:31:15 UTC
Created attachment 421348 [details]
yum.log

Comment 8 RHEL Product and Program Management 2010-06-07 16:14:36 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 9 Zachary Amsden 2010-06-08 00:19:57 UTC
I get the same install failure with 20100607 DVD.  Raising to urgent; this is a RHEL DVD install failure which hasn't been fixed.

Comment 10 Zachary Amsden 2010-06-08 00:31:38 UTC
I tried increasing guest memory to 768M and using the graphical installer.  This made no difference.  What's going on?

I'm doing nothing unusual during install, besides all the default selections, the only local settings are:

Timezone: Pacific/Honolulu
Root password: redhat

Comment 11 Chris Lumens 2010-06-08 13:39:05 UTC
Memory shouldn't have anything to do with this.  I'll take a look later today.

Comment 12 Chris Lumens 2010-06-08 18:21:02 UTC
This is because the format of the DVD is undetected (ID_FS_TYPE is not set in the udev structure), so anaconda cannot figure out what's a valid installation DVD and what's not.  This is likely due to a missing call to blkid in our udev rules file.

*** This bug has been marked as a duplicate of bug 600225 ***


Note You need to log in before you can comment on or make changes to this bug.