Bug 601041 - Unable to boot SMP RHEL6 VMs using kvmclock
Unable to boot SMP RHEL6 VMs using kvmclock
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Zachary Amsden
Red Hat Kernel QE team
:
Depends On: 600145 600225
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 00:23 EDT by Zachary Amsden
Modified: 2013-01-09 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 16:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zachary Amsden 2010-06-07 00:23:45 EDT
Description of problem:

Using upstream kvm module, running kvm-qemu from F13, I can no longer boot RHEL6 SMP VMs using kvmclock.  UP VMs work fine; non-kvmclock VMs also work.

I'm discarding the standard bug template here because the information I have doesn't apply. I don't have good enough data points of success vs. failure to determine if this is a regression with RHEL6, kvm-qemu in F13, upstream kvm, or perhaps, even the kvm-kmod module adapter.  However, no data is better than incorrect data.

The hardware I'm using is AMD hardware with very broken hardware TSC, which does frequency scaling and has C1 idle bugs.  However, the patches I've been working on are designed to work around these problems.. right now, with or without the patches, I can't boot a kvmclock VM in SMP mode.

It's not clear this is just my hardware; Glauber also reported a similar problem in latest testing.

Hopefully it is not really a RHEL6 bug, but starting as the most important release with the most stringent deadline is never a wrong choice when there is reasonable suspicion.
Comment 1 Zachary Amsden 2010-06-07 00:30:15 EDT
Note this is currently blocked by 600145; hoping to test Glauber's patches on the latest kernel, I downloaded the latest daily RHEL6 image.  It failed to install (and wiped my guest VM's disk in the process).
Comment 3 Avi Kivity 2010-06-07 01:24:52 EDT
What does "no longer" mean?  is it due to a change in the R6 kernel, or due to an upstream change?  Which change, precisely?
Comment 4 Dor Laor 2010-06-07 02:38:23 EDT
Also, better test 100% rhel6 components + guest. In theory your setup should work fine but there are too many factors that might get in the way
Comment 5 RHEL Product and Program Management 2010-06-07 02:52:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Glauber Costa 2010-06-07 10:15:23 EDT
Please re-test with kernel-2.6.32-33.el6.
It has all kvmclock patches in
Comment 7 Zachary Amsden 2010-06-07 22:40:30 EDT
Argh, 20100607 Server DVD fails to install in a VM.  What's going on!
Comment 8 Zachary Amsden 2010-06-07 22:41:02 EDT
I need to try RHEL6 on RHEL6 anyway, I'll try on another machine.
Comment 9 Zachary Amsden 2010-06-08 11:41:01 EDT
Well, the DVD also fails to install on my physical server; I get a black screen right when X is supposed to start.

RHEL6 and RHEL5 both used to install on this server, so either I'm using the wrong install media or we've got serious regressions in the RHEL6 installer.
Comment 10 Zachary Amsden 2010-06-11 16:13:59 EDT
Testing using a Glauberized kernel reveals successful SMP boot with kvmclock!

Note You need to log in before you can comment on or make changes to this bug.