Bug 600163 - Authentication is need to run '/usr/sbin/gnome-power-backlight-helper' as super user
Summary: Authentication is need to run '/usr/sbin/gnome-power-backlight-helper' as sup...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 604901 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 04:08 UTC by GoinEasy9
Modified: 2010-08-23 21:16 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 21:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
auth dialog (34.05 KB, image/png)
2010-08-22 18:11 UTC, ritz
no flags Details

Description GoinEasy9 2010-06-04 04:08:19 UTC
Description of problem: Notification window pops up with login screen and also after login on desktop.


Version-Release number of selected component (if applicable):
gnome-power-manager-2.31.1-1.fc14.i686

How reproducible: Cold power up or reboot.


Steps to Reproduce:
1. same as above
2.
3.
  
Actual results: Notification window appears


Expected results: Notification window doesn't appear.


Additional info: Notification window:
Authentication is need to run '/usr/sbin/gnome-power-backlight-helper' as super user
Command: /usr/sbin/gnome-power-backlight-helper --get-max-brightness

/var/log/secure from session:

Jun  3 23:31:05 localhost su: pam_unix(su:session): session closed for user root
Jun  3 23:31:14 localhost pam: gdm-password[1577]: pam_unix(gdm-password:session): session closed for user GoinEasy9
Jun  3 23:31:14 localhost polkitd(authority=local): Unregistered Authentication Agent for session /org/freedesktop/ConsoleKit/Session1 (system bus name :1.28, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Jun  3 23:31:14 localhost polkitd(authority=local): Unregistered Authentication Agent for session /org/freedesktop/ConsoleKit/Session2 (system bus name :1.55, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.utf8) (disconnected from bus)
Jun  3 23:32:27 localhost polkitd(authority=local): Registered Authentication Agent for session /org/freedesktop/ConsoleKit/Session1 (system bus name :1.30 [/usr/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Jun  3 23:33:33 localhost polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session1 successfully authenticated as unix-user:root to gain ONE-SHOT authorization for action org.freedesktop.policykit.exec for unix-process:1512:2216 [gnome-power-manager] (owned by unix-user:gdm)
Jun  3 23:33:33 localhost pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=42)
Jun  3 23:33:33 localhost pkexec[1527]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/gdm] [COMMAND=/usr/sbin/gnome-power-backlight-helper --get-max-brightness]
Jun  3 23:33:41 localhost pam: gdm-password[1530]: pam_unix(gdm-password:session): session opened for user GoinEasy9 by (uid=0)
Jun  3 23:33:53 localhost polkitd(authority=local): Registered Authentication Agent for session /org/freedesktop/ConsoleKit/Session2 (system bus name :1.52 [/usr/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
Jun  3 23:37:09 localhost polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as unix-user:root to gain ONE-SHOT authorization for action org.freedesktop.policykit.exec for unix-process:1693:10892 [gnome-power-manager] (owned by unix-user:GoinEasy9)
Jun  3 23:37:09 localhost pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=500)
Jun  3 23:37:09 localhost pkexec[1978]: GoinEasy9: Executing command [USER=root] [TTY=unknown] [CWD=/home/GoinEasy9] [COMMAND=/usr/sbin/gnome-power-backlight-helper --get-max-brightness]

It's possible I should have filed this under policykit, but, it was gnome-power-manager that was in the updates tonight.

Comment 1 Richard Hughes 2010-06-11 10:23:28 UTC
commit 9b0e1ae4f18a57f9aff2f89ccc156f0a4c46580f
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Jun 7 16:13:36 2010 +0100

    Do not require PolicyKit to get the brightness values as these are already accessible by all users
    
    This also fixes the random dialog when launching a session
    using VNC

:100644 100644 b89f7dc... 27aed09... M  src/gpm-backlight-helper.c
:100644 100644 323b37a... cc8233f... M  src/gpm-brightness.c

Comment 2 atswartz 2010-06-11 17:54:48 UTC
I am also getting this.  It is annoying.

Comment 3 Rahul Sundaram 2010-06-16 21:22:52 UTC
When are you pushing this update?

Comment 4 Richard Hughes 2010-06-17 07:41:59 UTC
(In reply to comment #3)
> When are you pushing this update?    

I'm stuck in limbo, as rawhide is so unstable for me. GLib needs to do a new upstream release so I can dep on it for the GApplication changes. There's a srpm here if you're feeling brave: http://people.freedesktop.org/~hughsient/fedora/13/SRPMS/

Richard.

Comment 5 Richard Hughes 2010-06-17 07:44:48 UTC
*** Bug 604901 has been marked as a duplicate of this bug. ***

Comment 6 Athmane Madjoudj 2010-06-23 21:21:06 UTC
I confirm that the following version fix the issue:
gnome-power-manager-2.31.3-1.f14

Comment 7 Richard Hughes 2010-06-23 21:40:20 UTC
Cool, thanks.

Comment 8 atswartz 2010-06-24 06:13:13 UTC
all good on x86_64 now


Note You need to log in before you can comment on or make changes to this bug.