Bug 600607 - kdump via bond device doesn't work for non-basic config.
kdump via bond device doesn't work for non-basic config.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
medium Severity high
: beta
: ---
Assigned To: Cong Wang
Han Pingtian
: Regression
Depends On:
Blocks: 5to6kexecTools
  Show dependency treegraph
 
Reported: 2010-06-05 03:26 EDT by CAI Qian
Modified: 2013-09-29 22:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-93_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 459879
Environment:
Last Closed: 2010-11-11 09:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.59 KB, patch)
2010-06-24 04:16 EDT, Cong Wang
no flags Details | Diff
updated version (1.83 KB, patch)
2010-06-28 06:24 EDT, Cong Wang
no flags Details | Diff
delta patch (1018 bytes, patch)
2010-06-30 02:02 EDT, Cong Wang
no flags Details | Diff
a correct patch (1012 bytes, patch)
2010-06-30 02:23 EDT, Cong Wang
no flags Details | Diff

  None (edit)
Comment 4 Han Pingtian 2010-06-23 23:48:04 EDT
None-basic bonding config still doesn't work well with -84.el6. Kdump drop into shell with this error messages:
...
Creating block device sda
 sda: sda1 sda2
Creating block device sr0
Making device-mapper control node
mdadm: No arrays found in config file or automatically
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "vg_ibmx365503" using metadata type lvm2
Activating logical volumes
  3 logical volume(s) in volume group "vg_ibmx365503" now active
mapping eth0 to eth4		<---------------?
ifup: duplicate interface "eth4"
ifconfig: bad address 'eth4'
eth4
eth4 failed to come up
Dropping to shell. exit to reboot
/ # 
...

/etc/sysconfig/network-scripts/ifcfg-eth0:
EVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:14:5E:5B:8D:43
ONBOOT=yes

/etc/sysconfig/network-scripts/ifcfg-bond1:
DEVICE=bond1
ONBOOT=yes
BONDING_OPTS="mode=1 miimon=100"

/etc/sysconfig/network-scripts/ifcfg-eth2:
DEVICE=eth2
ONBOOT=yes
SLAVE=yes
MASTER=bond1

/etc/sysconfig/network-scripts/ifcfg-eth3:
DEVICE=eth3
ONBOOT=yes
SLAVE=yes
MASTER=bond1

/etc/modprobe.conf:
alias eth0 bnx2
alias eth1 bnx2
alias eth2 e1000e
alias eth3 e1000e
alias eth4 e1000e
alias eth5 e1000e
alias eth6 ixgbe
alias bond1 bonding
Comment 5 Han Pingtian 2010-06-24 03:59:27 EDT
Made a mistake. Added two 'net nest.test.redhat.com:/mnt/qa' in /etc/kdump.conf. I am sorry.
Comment 6 Han Pingtian 2010-06-24 04:05:13 EDT
The verification of this bug is also blocked by 605011.
Comment 7 Cong Wang 2010-06-24 04:16:41 EDT
Created attachment 426482 [details]
proposed patch

Although this is a mistake in kdump.conf, but I think this patch is still needed.
Comment 9 Cong Wang 2010-06-28 06:24:31 EDT
Created attachment 427375 [details]
updated version
Comment 10 Cong Wang 2010-06-29 02:54:04 EDT
Neil,

With this patch applied, if there are two 'net' dump targets in kdump.conf, the last one will overwrite the previous one, without this patch, we will get the above errors in the second kernel. I know, we only support one dump target. :)

What do you think about this change?
Comment 11 Neil Horman 2010-06-29 09:18:36 EDT
yeah, I'm ok with it.  multiple dump targets aren't supported, but behavior isn't defined in terms of what happens if you do that, so I'm ok with the overwrite aspect.  Thanks!
Comment 13 Han Pingtian 2010-06-30 01:28:14 EDT
(In reply to comment #9)
> Created an attachment (id=427375) [details]
> updated version    

Looks like this patch still doesn't work:

...  
Reading all physical volumes.  This may take a while...
  Found volume group "vg_ibmx365503" using metadata type lvm2
Activating logical volumes
  3 logical volume(s) in volume group "vg_ibmx365503" now active
mapping bond1 to bond0
mapping eth0 to eth0
mapping eth1 to eth1
ifup: ignoring unknown interface bond0
bond0 failed to come up
Dropping to shell. exit to reboot
/ # ifconfig
/ # 
/ # cat /etc/iface_to_activate 
bond0
/ #
Comment 14 Cong Wang 2010-06-30 02:02:51 EDT
Created attachment 427867 [details]
delta patch

Pingtian, try if this patch can fix the problem.
Comment 15 Cong Wang 2010-06-30 02:23:46 EDT
Created attachment 427875 [details]
a correct patch
Comment 17 Han Pingtian 2010-07-01 02:53:56 EDT
Reproduced with -72.el6:
... ...
mdadm: No arrays found in config file or automatically
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "vg_ibmx365503" using metadata type lvm2
Activating logical volumes
  3 logical volume(s) in volume group "vg_ibmx365503" now active
mapping bond1 to bond0
mapping eth0 to eth0
mapping eth1 to eth1
mapping eth2 to eth2
mapping eth3 to eth3
ADDRCONF(NETDEV_UP): bond0: link is not ready
bond0 Link Up.  Waiting 60 Seconds
Continuing
searching for slaves
msh: /etc/ifcfg-eth4: No such file or directory
msh: /etc/ifcfg-eth5: No such file or directory
msh: /etc/ifcfg-eth6: No such file or directory
msh: /etc/ifcfg-lo: No such file or directory
msh: /etc/ifcfg-sit0: No such file or directory
udhcpc (v1.15.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
bond0 failed to come up
Dropping to shell. exit to reboot
/ # 

Verified with -95.el6:
... ...
mdadm: No arrays found in config file or automatically
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "vg_ibmx365503" using metadata type lvm2
Activating logical volumes
  3 logical volume(s) in volume group "vg_ibmx365503" now active
mapping bond1 to bond0
mapping eth0 to eth0
mapping eth1 to eth1
ADDRCONF(NETDEV_UP): bond0: link is not ready
bond0 Link Up.  Waiting 60 Seconds
Continuing
searching for slaves
enslaving eth0 tbonding: bond0: Adding slave eth0.
o bond0
bnx2: eth0: using MSI
bonding: bond0: Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.
bonding: bond0: enslaving eth0 as an active interface with an up link.
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
enslaving eth1 to bond0
bonding: bond0: Adding slave eth1.
bnx2: eth1: using MSI
bonding: bond0: Warning: failed to get speed and duplex from eth1, assumed to be 100Mb/sec and Full.
bonding: bond0: enslaving eth1 as an active interface with an up link.
udhcpc (v1.15.1) started
Sending discover...
Sending discover...
bnx2: eth0 NIC Copper Link is Up, 1000 Mbps full duplex
Sending discover...
Sending select for 10.16.68.96...
Lease of 10.16.68.96 obtained, lease time 86400
deleting routers
Comment 18 releng-rhel@redhat.com 2010-11-11 09:45:40 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.