Bug 600640 - virsh man page is missing all of the vol-* commands. Patch to include them attached.
virsh man page is missing all of the vol-* commands. Patch to include them a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
:
: 600641 (view as bug list)
Depends On: 602217
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-05 07:08 EDT by Justin Clift
Modified: 2010-11-11 09:49 EST (History)
8 users (show)

See Also:
Fixed In Version: libvirt-0_8_1-9_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds the vol-* commands to the virsh man page, as submitted upstream. (5.17 KB, patch)
2010-06-08 11:12 EDT, Justin Clift
no flags Details | Diff
tweaked to avoid merge conflict on rhel6 (5.34 KB, patch)
2010-06-09 08:48 EDT, Eric Blake
no flags Details | Diff

  None (edit)
Description Justin Clift 2010-06-05 07:08:51 EDT
Description of problem:

In RHEL 6 (beta), the virsh command has many available commands for working with volumes:

    vol-create      create a vol from an XML file
    vol-create-from create a vol, using another volume as input
    vol-create-as   create a volume from a set of args
    vol-clone       clone a volume.
    vol-delete      delete a vol
    vol-wipe        wipe a vol
    vol-dumpxml     vol information in XML
    vol-info        storage vol information
    vol-list        list vols
    vol-path        convert a vol UUID to vol path
    vol-name        convert a vol UUID to vol name
    vol-key         convert a vol UUID to vol key

However, the man page for virsh has no information regarding any of them.

The attached patch, also submitted upstream, adds them to the virsh man page.


Version-Release number of selected component (if applicable):

  libvirt-client-0.7.6-2.el6.x86_64

How reproducible:

Every time.


Steps to Reproduce:
1. man virsh
2. Look for any of the vol-* commands.  They're not there. :(


Actual results:

No result, as the info is missing.


Expected results:

Information on the usage of the vol-* commands.


Additional info:
Comment 3 Justin Clift 2010-06-05 07:18:52 EDT
Submitted upstream:

  https://www.redhat.com/archives/libvir-list/2010-June/msg00125.html
Comment 4 RHEL Product and Program Management 2010-06-05 08:42:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Justin Clift 2010-06-08 11:12:32 EDT
Created attachment 422248 [details]
Adds the vol-* commands to the virsh man page, as submitted upstream.
Comment 6 Dave Allan 2010-06-08 13:57:42 EDT
*** Bug 600641 has been marked as a duplicate of this bug. ***
Comment 7 Eric Blake 2010-06-09 08:10:55 EDT
The attached patch was applied upstream, but it includes documentation for vol-pool, which does not yet exist in RHEL6.  I'm creating another bug to add that, and this can depend on it (or we tweak the patch to remove a few lines).
Comment 8 Eric Blake 2010-06-09 08:48:15 EDT
Created attachment 422537 [details]
tweaked to avoid merge conflict on rhel6

merge conflict resolved: rhel6 build does not include e5f31f46 from upstream, which added a missing =back before SECRET COMMANDS.
Comment 10 Dave Allan 2010-06-16 16:50:05 EDT
libvirt-0_8_1-9_el6 has been built in RHEL-6-candidate with the fix.

Dave
Comment 13 xhu 2010-09-07 23:11:50 EDT
Verified this bug with RHEL6 RC build and it passed:
libvirt-0.8.1-27.el6.x86_64
qemu-kvm-0.12.1.2-2.113.el6.x86_64
kernel-2.6.32-70.el6.x86_64
Comment 14 releng-rhel@redhat.com 2010-11-11 09:49:57 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.