Bug 600641 - virsh man page is missing all of the vol-* commands. Patch to include them attached.
virsh man page is missing all of the vol-* commands. Patch to include them a...
Status: CLOSED DUPLICATE of bug 600640
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-05 07:12 EDT by Justin Clift
Modified: 2010-06-08 13:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 13:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the virsh man page to include the vol-* commands. (4.49 KB, patch)
2010-06-05 07:12 EDT, Justin Clift
no flags Details | Diff
Updated patch, as submitted upstream. (5.17 KB, patch)
2010-06-08 11:07 EDT, Justin Clift
no flags Details | Diff

  None (edit)
Description Justin Clift 2010-06-05 07:12:24 EDT
Created attachment 421415 [details]
Patch to the virsh man page to include the vol-* commands.

Description of problem:

In RHEL 6 (beta), the virsh command has many available commands for working with volumes:

    vol-create      create a vol from an XML file
    vol-create-from create a vol, using another volume as input
    vol-create-as   create a volume from a set of args
    vol-clone       clone a volume.
    vol-delete      delete a vol
    vol-wipe        wipe a vol
    vol-dumpxml     vol information in XML
    vol-info        storage vol information
    vol-list        list vols
    vol-path        convert a vol UUID to vol path
    vol-name        convert a vol UUID to vol name
    vol-key         convert a vol UUID to vol key

However, the man page for virsh has no information regarding any of them.

The attached patch, also submitted upstream, adds them to the virsh man page.


Version-Release number of selected component (if applicable):

  libvirt-client-0.7.6-2.el6.x86_64

How reproducible:

Every time.


Steps to Reproduce:
1. man virsh
2. Look for any of the vol-* commands.  They're not there. :(


Actual results:

No result, as the info is missing.


Expected results:

Information on the usage of the vol-* commands.


Additional info:
Comment 1 Justin Clift 2010-06-05 07:18:20 EDT
This is a duplicate of BZ #600640, just submitted.  (doubled up due to resubmitting, because of reported "Proxy Error" on first submission)
Comment 3 RHEL Product and Program Management 2010-06-07 13:03:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Justin Clift 2010-06-08 11:07:13 EDT
Created attachment 422245 [details]
Updated patch, as submitted upstream.
Comment 5 Dave Allan 2010-06-08 13:57:42 EDT
Closing as duplicate per Comment #1.

*** This bug has been marked as a duplicate of bug 600640 ***

Note You need to log in before you can comment on or make changes to this bug.