Bug 600851 - system-config-users fail to remove user
system-config-users fail to remove user
Status: CLOSED DUPLICATE of bug 602192
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 07:07 EDT by Matthieu Gautier
Modified: 2010-06-11 07:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 07:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Gautier 2010-06-06 07:07:49 EDT
Description of problem:

system-config-users fail to remove user. Probably if mail dir doesn't exist.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run system-config-users
2. Create an user
3. Remove it, A new window appears:
4. Select "remove user dir ..."
5. Click on yes. No graphical warning or other appear.
6. Close the window
7. Retry to remove it (and success)
  
Actual results:
Can't remove user.

Expected results:
Be able to remove user on the first try.


Additional info:
On terminal, the following error message:
Traceback (most recent call last):
  File "/usr/share/system-config-users/mainWindow.py", line 710, in on_delete_activate
    self.rmrf(mailSpool)
  File "/usr/share/system-config-users/mainWindow.py", line 890, in rmrf
    raise
TypeError: exceptions must be classes or instances, not NoneType
Comment 1 Nils Philippsen 2010-06-11 07:45:45 EDT

*** This bug has been marked as a duplicate of bug 602192 ***

Note You need to log in before you can comment on or make changes to this bug.