Bug 602192 - Removing user fails, TypeError: exceptions must be classes or instances, not NoneType
Summary: Removing user fails, TypeError: exceptions must be classes or instances, not ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 600851 603265 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-09 11:14 UTC by Kamil Páral
Modified: 2010-06-16 17:45 UTC (History)
3 users (show)

Fixed In Version: system-config-users-1.2.99-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-16 17:41:08 UTC
Type: ---


Attachments (Terms of Use)

Description Kamil Páral 2010-06-09 11:14:51 UTC
Description of problem:
When removing user:

Traceback (most recent call last):
  File "/usr/share/system-config-users/mainWindow.py", line 710, in on_delete_activate
    self.rmrf(mailSpool)
  File "/usr/share/system-config-users/mainWindow.py", line 890, in rmrf
    raise
TypeError: exceptions must be classes or instances, not NoneType

This happens after clicking Yes on dialog "Do you really want to remove user...?". Removing home dir is checked. The dialog stays open and must be closed by X button. Home dir is removed, but the user stays in the system. Removing the user for the second time finally completes the task.

Version-Release number of selected component (if applicable):
system-config-users-1.2.98-1.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1. Try to remove user with his home dir.
2. Observe the traceback.
3. User stays, home dir does not.

Comment 1 Nils Philippsen 2010-06-11 11:31:42 UTC
I made a mistake when fixing bug #539251 and have fixed this in the upstream repo:

http://git.fedorahosted.org/git/?p=system-config-users.git;a=commitdiff;h=8b7b11ecfc5eca7ff11ff1a6a1aee7b65bb58d18

Comment 2 Nils Philippsen 2010-06-11 11:45:45 UTC
*** Bug 600851 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2010-06-11 12:09:56 UTC
system-config-users-1.2.99-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-users-1.2.99-1.fc13

Comment 4 Fedora Update System 2010-06-11 12:11:30 UTC
system-config-users-1.2.99-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-users-1.2.99-1.fc12

Comment 5 Nils Philippsen 2010-06-14 08:55:35 UTC
*** Bug 603265 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-06-14 17:07:49 UTC
system-config-users-1.2.99-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-users'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-users-1.2.99-1.fc13

Comment 7 Fedora Update System 2010-06-16 17:41:04 UTC
system-config-users-1.2.99-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-06-16 17:45:02 UTC
system-config-users-1.2.99-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.