Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600852 - virt-manager doesn't support GNOME session management.
virt-manager doesn't support GNOME session management.
Status: CLOSED CANTFIX
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
:
: 600853 600855 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 07:15 EDT by Jo-Erlend Schinstad
Modified: 2012-01-25 15:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-25 15:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jo-Erlend Schinstad 2010-06-06 07:15:27 EDT
Description of problem:

virt-manager (0.8.2) is not affected by GNOME session management. When you log out of GNOME, virt-manager should save its state, size and position and start automatically at next login.
Comment 1 Cole Robinson 2010-08-19 10:57:46 EDT
*** Bug 600853 has been marked as a duplicate of this bug. ***
Comment 2 Cole Robinson 2010-08-19 10:57:50 EDT
*** Bug 600855 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2012-01-25 15:09:49 EST
After googling around a bit, sounds like session management WRT current gnome is really up in the air: there is no recommended or supported API for it whatsoever, and the option to enable is hidden in gnome-session-properties. The way most apps seem to do it now is either using the long deprecated gnome-client library, or embedding a library called libeggsmclient.

The latter isn't an option for us since it's a C library and we are python.

Eventually there might be a proper solution merged in gtk3 or glib, at which point I'll patch virt-manager. But until then it's like that session management is moving closer and closer towards oblivion, so truthfully not really worth tracking in a bug report. Closing as CANTFIX

Note You need to log in before you can comment on or make changes to this bug.