Bug 600878 - docbook-style-dsssl mucks with openjade's catalogs
docbook-style-dsssl mucks with openjade's catalogs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docbook-style-dsssl (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 601188
  Show dependency treegraph
 
Reported: 2010-06-06 09:15 EDT by Ville Skyttä
Modified: 2010-06-24 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: docbook-style-dsssl-1.79-11.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 601188 (view as bug list)
Environment:
Last Closed: 2010-06-24 12:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2010-06-06 09:15:28 EDT
# yum remove docbook-style-dsssl openjade
[...]
Running Transaction
  Erasing        : docbook-style-dsssl-1.79-10.fc13.noarch                                                                                                                           1/2 
Non-fatal <unknown> scriptlet failure in rpm package openjade
  Erasing        : openjade-1.3.2-36.fc13.x86_64                                                                                                                                     2/2 
Failed to remove entry from /etc/sgml/sgml-docbook-3.0-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-3.1-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.0-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.1-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.1.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.3-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.3-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.4-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.4-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.5-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.5-1.0-50.fc13.cat
warning: %triggerun(openjade-1.3.2-36.fc13.x86_64) scriptlet failed, exit status 1


This is because docbook-style-dsssl for some reason tries to manage openjade's catalogs, and doing so breaks the openjade trigger in docbook-dtds which tries to do the same thing.  It seems to me that docbook-style-dsssl should not be doing anything at all with openjade's catalogs, and at least the version from the openjade dependency could be dropped if this is implemented.

Another problem with managing them in docbook-style-dsssl is that removing docbook-style-dsssl results in openjade's catalogs being removed from the docbook catalogs in /etc/sgml even though openjade and the referred catalog is still installed.
Comment 1 Ondrej Vasik 2010-06-06 13:39:53 EDT
Thanks for report, will fix that...
Comment 2 Ondrej Vasik 2010-06-07 09:59:48 EDT
Fixed in rawhide - built as docbook-style-dsssl-1.79-11.fc14
Comment 3 Fedora Update System 2010-06-07 10:10:00 EDT
docbook-style-dsssl-1.79-11.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/docbook-style-dsssl-1.79-11.fc13
Comment 4 Fedora Update System 2010-06-08 15:39:30 EDT
docbook-style-dsssl-1.79-11.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update docbook-style-dsssl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/docbook-style-dsssl-1.79-11.fc13
Comment 5 Fedora Update System 2010-06-24 12:27:15 EDT
docbook-style-dsssl-1.79-11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.