Bug 601188 - docbook-style-dsssl mucks with openjade's catalogs
docbook-style-dsssl mucks with openjade's catalogs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: docbook-style-dsssl (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
Michal Nowak
:
Depends On: 600878
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 08:40 EDT by Ondrej Vasik
Modified: 2013-03-07 21:10 EST (History)
5 users (show)

See Also:
Fixed In Version: docbook-style-dsssl-1.79-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 600878
Environment:
Last Closed: 2010-11-10 15:18:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2010-06-07 08:40:33 EDT
+++ This bug was initially created as a clone of Bug #600878 +++

# yum remove docbook-style-dsssl openjade
[...]
Running Transaction
  Erasing        : docbook-style-dsssl-1.79-10.fc13.noarch                                                                                                                           1/2 
Non-fatal <unknown> scriptlet failure in rpm package openjade
  Erasing        : openjade-1.3.2-36.fc13.x86_64                                                                                                                                     2/2 
Failed to remove entry from /etc/sgml/sgml-docbook-3.0-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-3.1-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.0-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.1-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.1.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.2-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.3-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.3-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.4-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.4-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/sgml-docbook-4.5-1.0-50.fc13.cat
Failed to remove entry from /etc/sgml/xml-docbook-4.5-1.0-50.fc13.cat
warning: %triggerun(openjade-1.3.2-36.fc13.x86_64) scriptlet failed, exit status 1


This is because docbook-style-dsssl for some reason tries to manage openjade's catalogs, and doing so breaks the openjade trigger in docbook-dtds which tries to do the same thing.  It seems to me that docbook-style-dsssl should not be doing anything at all with openjade's catalogs, and at least the version from the openjade dependency could be dropped if this is implemented.

Another problem with managing them in docbook-style-dsssl is that removing docbook-style-dsssl results in openjade's catalogs being removed from the docbook catalogs in /etc/sgml even though openjade and the referred catalog is still installed.

--- Additional comment from ovasik@redhat.com on 2010-06-06 13:39:53 EDT ---

Thanks for report, will fix that...
Comment 1 RHEL Product and Program Management 2010-06-07 08:53:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-06-07 09:53:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 releng-rhel@redhat.com 2010-11-10 15:18:06 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.