Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600892 - Xorg fails to start on "Intel Corporation 82G33/G31" when kernel is booted with 'nomodeset' option
Xorg fails to start on "Intel Corporation 82G33/G31" when kernel is booted wi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 600949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 10:55 EDT by sudheer
Modified: 2010-10-25 17:16 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-25 17:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xserver log (8.16 KB, text/plain)
2010-06-06 10:55 EDT, sudheer
no flags Details

  None (edit)
Description sudheer 2010-06-06 10:55:00 EDT
Created attachment 421605 [details]
xserver log

Description of problem:

I have installed FC13 (x64) but X Server fails to start on my machine having "Intel Corporation 82G33/G31" Integrated Graphics Controller when the kernel is booted with 'nomodeset option'. When I realised that 'nomodeset' option in grub.conf was causing the issue so removed it and the X server started functioning.

Please find the attachment Xorg.0.log

My smolt id is

http://www.smolts.org/client/show/pub_f2d9c681-9168-4d4a-93d7-ba470a580124




Version-Release number of selected component (if applicable):

Fedora 13 x64 : xorg-x11-drv-intel-2.11.0-4.fc13.x86_64



Steps to Reproduce:
1. Edit grub.conf & add nomodeset to the kernel option list

  
Actual results:


Expected results:

X server will not start

Additional info:
Comment 1 Adam Williamson 2010-06-07 09:54:18 EDT
this is expected and intended behaviour in F13, the use of nomodeset is no longer supported with the intel driver.

perhaps we should make the 'nomodeset' option a no-op with intel and nouveau, and print a warning in logs somewhere? re-assigning to kernel with ajax and ben CC'ed for input.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2010-06-07 10:01:43 EDT
*** Bug 600949 has been marked as a duplicate of this bug. ***
Comment 3 Ben Skeggs 2010-06-07 18:20:21 EDT
I guess we could have some kind of message printed in the logs somewhere, I'd like to keep "nomodeset" however, as it's very useful in those situations where we fail to initialise the display for whatever reason.
Comment 4 Adam Williamson 2010-06-09 14:46:49 EDT
I'm not sure what you mean...how is it useful, when the X driver can't work with it? What's the point of loading nouveau with nomodeset versus just not loading it at all? Does it help for diagnostics somehow?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2010-06-09 14:48:00 EDT
Or do you just mean that it makes handling the situation easier for users, because it's easier to just put in 'nomodeset' than it is to actually disable the module?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Jackson 2010-10-25 17:16:35 EDT
We should fall back to vesa magically when you say "nomodeset" now.

Note You need to log in before you can comment on or make changes to this bug.