Bug 6009 - Upgrade can't find Linux partitions
Upgrade can't find Linux partitions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-16 20:04 EDT by J. Lucha
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 13:03:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Lucha 1999-10-16 20:04:16 EDT
I have RH6 installed and choosing the upgrade option during
the install it reports there are no linux partitions on my
system to upgrade.

I have a SCSI CDROM with an adaptec 2940 controller, but my
HD is IDE.  I had no problems upgrading my system from
previous versions using this setup ( 4.2 --> 5.0 --> 5.1 -->
6.0) but I suspect it's looking for a SCSI HD.

My filesystem layout is:

hda6 /
hda1 /mnt/win
hda3 /boot
hda7 /usr
hda8 /home
Comment 1 Jay Turner 1999-10-21 15:03:59 EDT
Please send me a copy of your fstab as well as dump from fdisk, as
there are known problems in these areas and seeing them will help
troubleshoot.
Comment 2 Jay Turner 1999-10-22 09:11:59 EDT
This bug is fixed by the installer updates on the errata site.
Comment 3 J. Lucha 1999-10-24 16:59:59 EDT
I downloaded the boot-RHEA-1999:044.img, and the
updates-RHEA-1999:045.img files, verified them with md5sum and made
diskettes from them.  I booted from the boot disk, and at the lilo
prompt entered "linux updates" and inserted the update disk when
prompted to do so.

It still reports no linux partitions found on my system when I choose
the upgrade installation method.

------- Additional Comments From   10/26/99 05:43 -------
I have got the sama problem, except I have only IDE-devices.
I downloaded bootnet-RHEA-1999:044.img and updates-RHEA-1999:045.img,
verified with md5sum, made them into diskettes and tried to update
with "linux updates expert". It asked for the update disk and read
it ok, but it still didn't detect any Linux partitions to update.
Here's my fstab
/dev/hda7     /            ext2    defaults        1 1
/dev/hda8     swap         swap    defaults        0 0
/dev/fd0      /mnt/floppy  ext2    noauto          0 0
/dev/cdrom    /mnt/cdrom   iso9660 noauto,ro       0 0
none          /proc        proc    defaults        0 0
none          /dev/pts     devpts  mode=0622       0 0
/dev/hda1     /mnt/c       vfat    defaults        0 0
/dev/hda5     /mnt/d       vfat    defaults        0 0
/dev/hda6     /mnt/e       vfat    defaults        0 0
and fdisk -l
Disk /dev/hda: 255 heads, 63 sectors, 1869 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       255   2048256    b  Win95 FAT32
/dev/hda2           256      1869  12964455    f  Win95 Ext'd (LBA)
/dev/hda5           766      1275   4096543+   b  Win95 FAT32
/dev/hda6          1276      1869   4771273+   b  Win95 FAT32
/dev/hda7           256       734   3847504+  83  Linux
/dev/hda8           735       765    248976   82  Linux swap
Comment 4 Jay Turner 1999-11-02 13:03:59 EST
We are aware that the "f"-type partition problem is not fixed in the
latest errata update.  We are in the process of putting together
another errata release which will resolve this, but until then, the
best workaround is to temporarily change the "f"-type partition to
type "5" (also extended), perform the upgrade and then change the
partition back to type "f".  Please refer to bug #5511 for more
information about this fix.

*** This bug has been marked as a duplicate of 5511 ***

Note You need to log in before you can comment on or make changes to this bug.