Bug 5511 - Installer doesn't detect existing Linux installations
Installer doesn't detect existing Linux installations
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-04 16:21 EDT by Ian Macdonald
Modified: 2015-01-07 18:38 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-08 10:48:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Macdonald 1999-10-04 16:21:11 EDT
When upgrading a previous RHL installation that has its /
file system on the second hard drive (e.g. /dev/hdb), this
is not detected by the installation program (either the
graphical or the textual install). It fails, complaining
that no Linux partitions can be found.

The workaround is to make a copy of the / fs on /dev/hda
(assuming there is enough room). Apparently, the installer
needs to find your /etc/fstab on the first disc, so it will
then find this and detect all the other partitions on
/dev/hdb. Files upgraded on the / fs will be upgraded on
/dev/hdb, not the copy on /dev/hda.

------- Additional Comments From   10/06/99 19:38 -------
I have the same problem and my / is on hda3. It tries
mounting /dev/hda1(which is NTFS on win2000 rc1) and fails. It then
sits at the detecting redhat installtion forever(gui or text). It
does not appear to be restricted to the root being on separate drives.
RH6.0 upgrading to 6.1.
Comment 1 steve 1999-10-08 18:18:59 EDT
I tracked the problem down.  If the existing linux partitions are in
an extended partition of type "f" WIN9X Extended LBA, the installer
doesn't see them.  Change the partition to type 5, try the upgrade
again, and everything will work.
Comment 2 Jay Turner 1999-10-20 12:11:59 EDT
*** Bug 5500 has been marked as a duplicate of this bug. ***

My partition table looks like this:

hda1 fat32 windows 98
hda2 extended
hda5 fat16
hda6 linux native /
hda7 linux swap
hda3 linux native /boot

I have copied RedHat and dosutils to hda5 and I am trying
to do a hard disk install.

When I get to the Select Partition screen it shows three
partitions, hda1, hda2 and hda3. I want to select hda5 but
I can't. Even in expert mode there is no way to select
other partitions.
Comment 3 Jay Turner 1999-10-21 15:29:59 EDT
*** Bug 6038 has been marked as a duplicate of this bug. ***

My system is a PII400, with an Adaptec 2940U2W/IBM scsi
disk/Seagate tapedrive, and a ide-cdrom attached as primary
master. When trying to uopgrade, the system reports that I
don't have any linux partitions (which I do). Have tried to
disconnect the tape drive from the scsi-chain in order to
make sure ther where no termination errors, with no luck.
Neither graphics, text or expert-mode work. Also tried the
option aic7xxx=no_probe and still no reported linux

Below some system information and reported messages

/dev/sda5	/	ext2	defaults	1 1
/dev/sda6	/abab	ext2	defaults	1 2
/dev/sda1	/boot	ext2	defaults	1 2
/dev/sda8	/home	ext2	defaults	1 2
/dev/sda7	/usr	ext2	defaults	1 2
/dev/sda9	/var	ext2	defaults	1 2
/dev/sda2	swap	ext2	defaults	0 0
/dev/fd0	/mnt/floppy	ext2	noauto	0 0
/dev/cdrom	/mnt/cdrom	is9660	noauto, ro	0 0
none		/proc	proc	defaults	0 0
none		/dev/pts	devpts	gid=5,mode620	0 0

* probing buses
* finished bus probing
* found suggestion of aic7xxx
* found aic7xxx device
* found devices justprobe is 0
* going to insmod aic7xxx.o (path is NULL)
* trying to mount device hda
* probing buses
* finished bus probing
* found suggestion of 3c59x
* found 3c59x device
* found suggestion of aic7xxx
* found aic7xxx device
* found suggestion of Card:ATI Mach64 3D Rage IIC
* found devices justProbe is 0
* going to insmod 3c59x.o (path is NULL)
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod raid5.o (path is NULL)
*** After second upgrade attempt
* Error in swapon of sda2: Device or resource busy

scsi0: Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI)
       <Adaptec AHA-294x Ultra2 SCSI host adapter>
scsi  : 1 host.
(scsi0:0:0:0) Synchronus at 80,0 Mbyte/sec, offset 15.
  Vendor: IBM	Model: DDRS-39130D	REV: DC1B
  Type:	Direct-Access			ANSI SCSI revision:
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:4:0) Synchronous at 10.0 Mbyte/sec, offset 15
  Vendor: Seagate Model: STT8000N	REV: 3.22
  Type: Sequential-Access		ANSI SCSI revision:
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17850000
[8715 MB] [8.7 GB]
 sda: sda1 sda2 sda3 < sda5 sda6 sda7 sda8 sda9 >
VFS: Disk change detected on device ide0(3,0)
ISO 9660 Extensions: Microsoft Joliet Level 1
ISO 9660 Extensions: RRIP_1991A
3c59x.c:v0.99H 11/17/98 Donald Becker (etc, left out)
eth0: 3Com 3c905B Cyclone 100BaseTx at 0xe800,
00:50:04:69:d3:20, IRQ 5
  8K byte-wide RAM 5:3 Rx:Tx split,
autoselect/Autonegotiate interface.
  MII transceivier found at address 24, status 782d.
  Enabling bus-mastert transmits and whole-fram recevies.
raid0 personality registered
raid1 personality registered
raid5 personality registered
*** After first upgrade attempt
Adding Swap: 136544k swap-space (prioroty -1)

------- Additional Comments From jturner@redhat.com  10/18/99 12:42 -------
Don't know whether this is a mistype of what, but one problem is that
the swap partition that you have listed below is of type ext2 and
should be of type swap.  Now, from the other messages that you
attached, I cannot tell what the problem is.  The system is seeing all
of your partitions and therefore should be able to find the existing
installation and should perform the upgrade on those partitions.  Send
me more error output and let me know where you are seeing the problem.

------- Additional Comments From peter.lofgren@mandator.se  10/19/99 16:30 -------
The ext2 for swap was a typo, it is 'swap' in my fstab.
The error message 'You don't have any Linux partitions. You can't
upgrade this system!' is seen right after I choose the upgrade option.
Have tried to find any additional error messages for you, but this is
all thats printed on the tty's. Is there any additional place to look?

This is the only additional output (tty4) that I've seen
hda: irq timeout: status=0xd0 { Busy }
hda: ATAPI reset complete

Also tried to set sda1 (/boot) as active, none of the partions where
set as active. Didn't help. Also, the 'DOS-large disk option' in the
adaptec bios is disabled (have tried both settings)

Since the system is able to swapon my sda2 swap space, I guess the
installer is seing my SCSI disk. It is also correctly reported in
disk druid choosing custom install (without going any further).

My theory:
All the original partitioning was done using Partion Magic 4.01.
Using fdisk, and the p option list the partition id as 83, and 82 for
swap. But the extended partition is type f - win95, where the root
partition is enclosed. You think it might help if changed to 85 Linux
extended, or 5 Extended. How do i go about, and change it, and what
security measures should I take?

Some additional info on my system
disk gemoetry (C/H/S) (1111/255/63) reported by disk druid
Award Modular Bios 4.51PG
1st Mainboard, intel 440BX
Adaptec AHA2940U2W v2.20.0 (upgraded from v2.01, tried upgrading
before and after)

------- Additional Comments From cks@cquest.utoronto.ca  10/21/99 04:15 -------
 As you've guessed, the problem is that the extended partition type
is set to '0f' (Windows Extended) instead of '05' (plain Extended).
Anaconda (the installer in 6.1) specifically only looks for extended
partitions inside a type '05' primary partition. One person here
(with this problem) experienced no problems in simply changing the
partition type from 0f to 05.

 In general, I suspect that Anaconda's disk partition parsing is
fragile. Perhaps in future releases, RedHat should just copy the
code from fdisk or the like (even if it is larger).

 Curious people can look in misc/src/anaconda/balkan/dos.c on the
install image for the gory details.

------- Additional Comments From   10/22/99 00:50 -------
I am having exactly the same problem: will someone please give the
recipe for changing the extended partition type from type 0f to 05
(what tool and exact procedure).

Comment 4 Jay Turner 1999-10-22 14:23:59 EDT
*** Bug 5622 has been marked as a duplicate of this bug. ***

I have a dual boot system with win98 and 6.0. I booted your
6.1 disk, after selecting upgrade it said no linux
partitions found.  Just to check I then selected install
and fdisk, which found my linux partitions. Also on
rebooting I was able to boot into 6.0.  I tried this
So your install/upgrade program is broken.

------- Additional Comments From dkl@redhat.com  10/06/99 16:08 -------
We will need you to post a copy of your current /etc/fstab from your
6.0 installation as well as a copy of what fdisk -l lists.

------- Additional Comments From jturner@redhat.com  10/20/99 15:56 -------
Do you have any Win98 extended partitions on your machine?  These
would appear in fdisk as type "f"  . . . there are known problems with
these partitions and a fix is being distributed the week of October
Comment 5 Jay Turner 1999-11-02 13:03:59 EST
*** Bug 6009 has been marked as a duplicate of this bug. ***

I have RH6 installed and choosing the upgrade option during
the install it reports there are no linux partitions on my
system to upgrade.

I have a SCSI CDROM with an adaptec 2940 controller, but my
HD is IDE.  I had no problems upgrading my system from
previous versions using this setup ( 4.2 --> 5.0 --> 5.1 -->
6.0) but I suspect it's looking for a SCSI HD.

My filesystem layout is:

hda6 /
hda1 /mnt/win
hda3 /boot
hda7 /usr
hda8 /home

------- Additional Comments From jturner@redhat.com  10/21/99 15:03 -------
Please send me a copy of your fstab as well as dump from fdisk, as
there are known problems in these areas and seeing them will help

------- Additional Comments From jturner@redhat.com  10/22/99 09:11 -------
This bug is fixed by the installer updates on the errata site.

------- Additional Comments From lucha@pe.net  10/24/99 16:59 -------
I downloaded the boot-RHEA-1999:044.img, and the
updates-RHEA-1999:045.img files, verified them with md5sum and made
diskettes from them.  I booted from the boot disk, and at the lilo
prompt entered "linux updates" and inserted the update disk when
prompted to do so.

It still reports no linux partitions found on my system when I choose
the upgrade installation method.

------- Additional Comments From   10/26/99 05:43 -------
I have got the sama problem, except I have only IDE-devices.
I downloaded bootnet-RHEA-1999:044.img and updates-RHEA-1999:045.img,
verified with md5sum, made them into diskettes and tried to update
with "linux updates expert". It asked for the update disk and read
it ok, but it still didn't detect any Linux partitions to update.
Here's my fstab
/dev/hda7     /            ext2    defaults        1 1
/dev/hda8     swap         swap    defaults        0 0
/dev/fd0      /mnt/floppy  ext2    noauto          0 0
/dev/cdrom    /mnt/cdrom   iso9660 noauto,ro       0 0
none          /proc        proc    defaults        0 0
none          /dev/pts     devpts  mode=0622       0 0
/dev/hda1     /mnt/c       vfat    defaults        0 0
/dev/hda5     /mnt/d       vfat    defaults        0 0
/dev/hda6     /mnt/e       vfat    defaults        0 0
and fdisk -l
Disk /dev/hda: 255 heads, 63 sectors, 1869 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       255   2048256    b  Win95 FAT32
/dev/hda2           256      1869  12964455    f  Win95 Ext'd (LBA)
/dev/hda5           766      1275   4096543+   b  Win95 FAT32
/dev/hda6          1276      1869   4771273+   b  Win95 FAT32
/dev/hda7           256       734   3847504+  83  Linux
/dev/hda8           735       765    248976   82  Linux swap
Comment 6 tdyas 1999-11-13 23:25:59 EST
With the 044 boot.img and the 045 update.img disks, the
installer still fails to recognize my Linux partitions which
are stored entirely within a Win98-style extended partition.
The particular error message was that it "could not find any
Linux partitions".

Here is my partition table:

Disk /dev/hda: 255 heads, 63 sectors, 1582 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       261   2096451    b  Win95
/dev/hda2           262      1582  10610932+   f  Win95
Ext'd (LBA)
/dev/hda5           262       522   2096451    b  Win95
/dev/hda6           523       539    136521   83  Linux
/dev/hda7           540       556    136521   82  Linux swap
/dev/hda8           557       622    530113+  83  Linux
/dev/hda9           623       655    265041   83  Linux
/dev/hda10          656      1102   3590496   83  Linux
/dev/hda11         1103      1582   3855568+  83  Linux

Here is /etc/fstab:

/dev/hda6               /                       ext2
defaults        1 1
/dev/hda11              /home                   ext2
defaults        1 2
/dev/hda9               /tmp                    ext2
defaults        1 2
/dev/hda10              /usr                    ext2
defaults        1 2
/dev/hda8               /var                    ext2
defaults        1 2
/dev/hda7               swap                    swap
defaults        0 0
/dev/fd0                /mnt/floppy             ext2
noauto,user     0 0
/dev/cdrom              /mnt/cdrom              iso9660
noauto,ro,user  0 0
none                    /proc                   proc
defaults        0 0
none                    /dev/pts                devpts
gid=5,mode=620       0 0

Is the source for the version of the Python balkan module on
the 045 updates disk available? I loaded it into the interactive python prompt
and it does not detect any of the partitions in the extended partition. If you
have the source, I'll try and see what is wrong.

Bug 6522 is a duplicate of this one then.
Comment 7 Jay Turner 1999-11-22 09:25:59 EST
*** Bug 7212 has been marked as a duplicate of this bug. ***
Comment 8 tdyas 1999-11-27 13:59:59 EST
I was able to get the upgrade to work by copying _balkanmodule.so from Rawhide
onto the :045 updates disk. Everything proceeded normally after that.
Comment 9 Jay Turner 1999-11-30 09:36:59 EST
*** Bug 6681 has been marked as a duplicate of this bug. ***
Comment 10 Jay Turner 1999-12-06 09:17:59 EST
*** Bug 6713 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.