Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600976 - kcm-gtk does not control cursor theme, loses settings
kcm-gtk does not control cursor theme, loses settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kcm-gtk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 17:47 EDT by Ville Skyttä
Modified: 2011-03-14 14:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.5.3-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 12:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2010-06-06 17:47:51 EDT
kcm-gtk does not currently allow one to control the cursor theme which is annoying, and even more annoying is that if one sets it manually in ~/.gtkrc-2.0-kde4, after using the kcm-gtk UI and applying settings there, gtk-cursor-theme-name disappears from ~/.gtkrc-2.0-kde4.

There's a patch that supposedly adds support for setting cursor themes at https://bugs.launchpad.net/kcm-gtk/+bug/505988 which upstream says has been applied for the next version; I haven't tested it but assuming it works it sounds like a good addition to the Fedora kcm-gtk package while waiting for the next upstream release.
Comment 1 Ville Skyttä 2010-07-06 13:00:31 EDT
Argh, I just got bitten by this issue again.  Would you like me to take a look at taking care of this?
Comment 2 Rex Dieter 2010-07-06 13:30:24 EDT
Any assistance would certainly be welcome, sure.

(Otherwise, sorry this fell off my radar).
Comment 3 Ville Skyttä 2010-07-06 17:16:18 EDT
Committed and built for devel, tested locally + works for me in F-13.  I'll leave <= F-13 branches for you to take care of if you think this is worth an update; otherwise feel free to close e.g. as RAWHIDE.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2298996
Comment 4 Kevin Kofler 2011-03-14 14:45:16 EDT
FYI, the cursor theme will now be handled automatically by xsettings-kde as per bug #591746, so we're dropping this patch. (We will have to hide or remove the setting when upgrading to a new kcm-gtk upstream version. It doesn't make sense to show a setting which will be ignored.)

The patch I wrote for xsettings-kde is much smaller than this one, so IMHO it should have been done there in the first place.

Note You need to log in before you can comment on or make changes to this bug.