Bug 601281 - IcedTea does not launch/run Power E*Trade Pro, a Java client application
IcedTea does not launch/run Power E*Trade Pro, a Java client application
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 11:48 EDT by iitm07-golf
Modified: 2010-10-13 17:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 17:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Java version info (142 bytes, application/octet-stream)
2010-07-12 20:14 EDT, iitm07-golf
no flags Details
Log of Power E*Trade Pro launch by Iced Tea Web Start (10.84 KB, application/octet-stream)
2010-07-12 20:16 EDT, iitm07-golf
no flags Details

  None (edit)
Description iitm07-golf 2010-06-07 11:48:03 EDT
Description of problem:  Power E*Trade Pro, a Java client, does not load/launch with IcedTea Web Start.  It worked fine with Java Web Start in Fedora8.


Version-Release number of selected component (if applicable):  I don't know.


How reproducible:  Very (every time)


Steps to Reproduce:  (Requires a E*Trade account/login, and requires access to Power E*Trade Pro software, a premium feature)
1.  Start Firefox.  Connect to www.etrade.com.  Log in.  Make sure you are on the Accounts page.
2.  Click on the Start button for Power E*TRade Pro.
3.  Click OK on the dialog box suggesting opening the .jnlp file with IcedTea Web Start.
  
Actual results:  A etpro_launch.jnlp file is downloaded, and a dialog box appears suggesting to open with IcedTea Web Start.  Click OK.  The dialog box disappears, and nothing happens.  (I don't remember if there is a brief display of the Iced Tea splash.  There is for Java Web Start in Fedora8.)


Expected results:  The application running, and displaying streaming quotes from E*Trade.


Additional info:
Comment 1 iitm07-golf 2010-06-07 12:05:42 EDT
May be related to Bugs 304031, 415061.  The Java application Power E*Trade Pro has two signatures (I think the launcher has a signature and then the application has a signature).  In both cases the signatures are invalid (Java Web Start displays notifications to that effect), probably because the server names don't match the ones in the certificates.
Comment 2 Omair Majid 2010-07-01 10:42:25 EDT
Hi

Unfortunately, I dont have access to an E*Trade account, so I am going to need your help to fix this. 

Could you please post the result of 'java -version'?

Could you please try saving the jnlp file and running it from the command line using the javaws program? Please post any debug output.

javaws -verbose etrade.jnlp

(replace etrade.jnlp with the name of the actual jnlp file)

Thanks
Comment 3 iitm07-golf 2010-07-12 20:14:46 EDT
Created attachment 431305 [details]
Java version info
Comment 4 iitm07-golf 2010-07-12 20:16:41 EDT
Created attachment 431307 [details]
Log of Power E*Trade Pro launch by Iced Tea Web Start
Comment 5 Omair Majid 2010-08-20 16:16:30 EDT
Thanks for the logs. I think I understand what the problem is. This patch should fix the problem: http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2010-August/010005.html
Comment 6 Andrew John Hughes 2010-10-13 17:57:45 EDT
This should be fixed in the upcoming java-1.6.0-openjdk-1.6.0.0-43.1.8.2.fc13.  Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.