Bug 601365 - Alps touchpad and point stick not recognized on Latitude E6510
Alps touchpad and point stick not recognized on Latitude E6510
Status: CLOSED DUPLICATE of bug 590880
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 15:18 EDT by Derek P. Moore
Modified: 2010-11-02 08:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 473894
Environment:
Last Closed: 2010-11-02 08:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek P. Moore 2010-06-07 15:18:32 EDT
+++ This bug was initially created as a clone of Bug #473894 +++

I have reported this bug upstream:
https://bugzilla.kernel.org/show_bug.cgi?id=16146

Description of problem:
My DualPoint trackball & touchpad work, but they are not recognized as Alps (they are recognized as "PS/2 Generic").  Without recognition, scrolling does not work, but tapping does.

I checked kernel source 'drivers/input/mouse/alps.c' & have confirmed that it is missing my device's bus/vendor/product ID triplet:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse2 event7 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I compiled a custom kernel to include my device ID triplet with byte mask "0xf8, 0xf8" & flags "ALPS_PASS | ALPS_DUALPOINT", but that didn't enable recognition.  I'll try other options & update this ticket & upstream ticket upon success.

The trackball has 3 buttons; the touchpad has 2 buttons with vertical &
horizontal scroll indicators.
Comment 1 Nate P. 2010-11-01 17:10:19 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=590880 and https://bugzilla.redhat.com/show_bug.cgi?id=616243

The patch from this post: https://bugzilla.kernel.org/show_bug.cgi?id=14660#c32
seems to be semi-working based on this post https://bugzilla.redhat.com/show_bug.cgi?id=590880#c19 from the E6410 touchpad bug page.

There is also another patch at: https://patchwork.kernel.org/patch/118834/ that some success has been reported with.

Hope some progress can be made on this before I receive my E6510.
Comment 2 Jan Vcelak 2010-11-02 08:07:01 EDT

*** This bug has been marked as a duplicate of bug 590880 ***

Note You need to log in before you can comment on or make changes to this bug.