Bug 601608 - [abrt] crash in deja-dup-14.1-1.fc13: IA__g_convert_with_fallback: Process /usr/bin/deja-dup-monitor was killed by signal 11 (SIGSEGV)
[abrt] crash in deja-dup-14.1-1.fc13: IA__g_convert_with_fallback: Process /u...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: deja-dup (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:0fcf7674dcaef6655d2d72f6e3a...
:
: 601660 603431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 06:14 EDT by walid bahgat
Modified: 2010-12-17 03:21 EST (History)
2 users (show)

See Also:
Fixed In Version: deja-dup-16.1-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 03:21:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.02 KB, text/plain)
2010-06-08 06:14 EDT, walid bahgat
no flags Details

  None (edit)
Description walid bahgat 2010-06-08 06:14:45 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/deja-dup-monitor
component: deja-dup
crash_function: IA__g_convert_with_fallback
executable: /usr/bin/deja-dup-monitor
global_uuid: 0fcf7674dcaef6655d2d72f6e3a6787f598fab16
kernel: 2.6.33.5-112.fc13.x86_64
package: deja-dup-14.1-1.fc13
rating: 3
reason: Process /usr/bin/deja-dup-monitor was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 walid bahgat 2010-06-08 06:14:48 EDT
Created attachment 422130 [details]
File: backtrace
Comment 2 Rahul Sundaram 2010-06-08 11:47:32 EDT
*** Bug 601660 has been marked as a duplicate of this bug. ***
Comment 3 Michael Terry 2010-06-13 10:19:18 EDT
I'm not sure how Deja Dup itself could be causing this crash.  It simply calls g_volume_monitor_get(), and then gio crashes trying to start the gvfs-gdu-volume-monitor daemon:

"invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/libexec/gvfs-gdu-volume-monitor re..."

This bug looks similar to bug 496324 and bug 509733 but is probably not the same.

Can /usr/libexec/gvfs-gdu-volume-monitor be run manually?
Comment 4 walid bahgat 2010-06-17 04:46:33 EDT
no still it gives me error, below is the out of /usr/libexec/gvfs-gdu-volume-monitor


(process:2899): libgdu-WARNING **: Couldn't get daemon properties
======================================================================
Error constructing GduPool: (unspecified error)

This error suggests there's a problem with your udisks or D-Bus installation.
======================================================================

(process:2899): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:2899): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(process:2899): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:2899): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(process:2899): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:2899): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(process:2899): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:2899): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
**
libgdu:ERROR:gdu-pool.c:2565:gdu_pool_get_presentables: assertion failed: (pool != NULL)
Aborted (core dumped)
Comment 5 Karel Klíč 2010-11-09 11:50:00 EST
*** Bug 603431 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-12-08 03:40:28 EST
deja-dup-16.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/deja-dup-16.1-2.fc14
Comment 7 Fedora Update System 2010-12-08 16:36:35 EST
deja-dup-16.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update deja-dup'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/deja-dup-16.1-2.fc14
Comment 8 Fedora Update System 2010-12-17 03:20:48 EST
deja-dup-16.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.