Bug 60205 - pcmcia confused about network interfaces on Dell Latitude C610
pcmcia confused about network interfaces on Dell Latitude C610
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-21 18:25 EST by Matthew Saltzman
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:20:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-02-21 18:25:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
On Dell Latitude C610 with built-in ethernet and mini-pci wireless card, I have
problems controlling the two interfaces separately.   eth1 (wireless) will not
start unless eth0 (ether) is up.  eth0 will not start if pcmcia is running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Set up /etc/sysconfig/ifcfg-eth1 by hand (see bug 56647).  Set ONBOOT=no for
both eth0 and eth1.
2.  Pick a scenario below.

Scenario 1:
2.  "ifup eth0"

Scenario 2:
2.  "ifup eth1"
	

Actual Results:  Scenario 1: eth0 (which is dhcp) hangs and eventually times
out.

Scenario 2: No-op (eth1 does not come up, no message, no hang, no network).

Expected Results:  Scenario 1: eth0 should receive it's dhcp information and
start.

Scenario 2: eth1 should receive it's dhcp information and start.

Additional info:

Scenario 1:  I can get eth0 to start by executing "service pcmcia stop" followed
by "ifup eth0".

Scenario 2:  I can get eth1 to start by executing "service pcmcia stop" followed
by "ifup eth0" (but must have cable plugged in),  followed by "service pcmcia
start".
If I try to "service pcmcia restart" when eth0 is running, log messages indicate
that the network attempts to start eth0, but if eth0 is already running, it
starts eth1.
Comment 1 Matthew Saltzman 2002-05-14 16:49:01 EDT
Update: With 7.3, the problem does not occur in most cases, however there is
still one problem scenario left.

On resuming after suspend to RAM, eth1 does not come up.  In order to get it to
come up, I need to perform the steps listed above (and recapped below):

(1) service pcmcia stop
(2) ifup eth0     (with no cable attached)
(3) service pcmcia start
(4) ifup eth1

All other scenarios tested so far seem to work in 7.3.
Comment 2 Arjan van de Ven 2002-05-21 08:45:13 EDT
question: does it help if you add
resume=force

to the end of the line with "vmlinuz" in the /etc/grub/grub.conf file ?
Comment 3 Matthew Saltzman 2002-05-23 13:37:05 EDT
I tried the following: Set resume=force, set eth0 down and eth1 up.  Suspend and
resume.  The effect is that eth0 attempts to start (which it should not do,
since it was down at suspend).  When eth0 times out, eth1 starts.

So yes, resume=force seems to help, but the behavior is still not perfect.  It
seems like I would want things that were down to stay down and things that were
up to attempt to come up on resume.  Perhaps this is repated to bug 47529?
Comment 4 Matthew Saltzman 2003-02-03 15:42:59 EST
This is still the behavior in RHL 8.0.

Note You need to log in before you can comment on or make changes to this bug.