Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602117 - PackageKit error while trying to install required packages
PackageKit error while trying to install required packages
Status: CLOSED DUPLICATE of bug 592410
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 03:52 EDT by Jaroslav Reznik
Modified: 2010-10-14 12:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-14 12:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2010-06-09 03:52:42 EDT
Description of problem: PackageKit throws error while trying to install required packages (libvirt).


Version-Release number of selected component (if applicable):
virt-manager-0.8.3-3.fc13.noarch

Steps to Reproduce:
1. run virt-manager without libvirt
2. "Packages required for KVM usage" click "Yes"
  
Actual results:
Error talking to PackageKit: org.freedesktop.DBus.Error.UnknownMethod: No such method 'InstallPackageNames' in interface 'org.freedesktop.PackageKit.Modify' at object path '/org/freedesktop/PackageKit' (signature 'iass')

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 129, in check_packagekit
    packagekit_install(do_install)
  File "/usr/share/virt-manager/virtManager/engine.py", line 159, in packagekit_install
    pk_control.InstallPackageNames(0, package_list, "hide-confirm-search")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such method 'InstallPackageNames' in interface 'org.freedesktop.PackageKit.Modify' at object path '/org/freedesktop/PackageKit' (signature 'iass')


Expected results:
Required packages correctly installed.
Comment 1 Cole Robinson 2010-10-14 12:02:02 EDT

*** This bug has been marked as a duplicate of bug 592410 ***

Note You need to log in before you can comment on or make changes to this bug.