Bug 602409 - nash doesn't support dirsync mount option
nash doesn't support dirsync mount option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: 590060 726828 668957 758797
  Show dependency treegraph
 
Reported: 2010-06-09 15:41 EDT by Casey Dahlin
Modified: 2014-06-18 04:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: mkinitrd-5.1.19.6-73
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:33:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for isse (1.38 KB, patch)
2010-06-11 12:38 EDT, Casey Dahlin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0157 normal SHIPPED_LIVE mkinitrd bug fix update 2012-02-20 09:54:17 EST

  None (edit)
Description Casey Dahlin 2010-06-09 15:41:37 EDT
nash doesn't support the dirsync mount option for ext3, meaning that if the option is rolled in for / from fstab, the system does not boot.

Patch is attached.
Comment 1 Casey Dahlin 2010-06-11 12:38:43 EDT
Created attachment 423332 [details]
Patch for isse

NOW the patch is attached. BZ is odd.
Comment 8 RHEL Product and Program Management 2011-08-05 08:33:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Jan Stodola 2012-01-02 07:31:53 EST
Reproduced with RHEL-5.7, mkinitrd-5.1.19.6-71.el5:
...
Creating root device.
Mounting root filesystem.
EXT3-fs: Unrecognized mount option "dirsync" or missing value
mount: error mounting /dev/root Kernel panic - not syncing: Attempted to kill init!
on /sysroot as e xt3: Invalid arg


Retested with 5.8 Snap 2, mkinitrd-5.1.19.6-75.el5, system booted without any problem:
...
Creating root device.
Mounting root filesystem.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting internal defaults
Switching to new root and running init.
...

[root@chicken ~]# mount | grep ' / '
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw,dirsync)


Moving to VERIFIED
Comment 11 errata-xmlrpc 2012-02-21 00:33:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0157.html

Note You need to log in before you can comment on or make changes to this bug.