Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602412 - Cannot open screenshot images
Cannot open screenshot images
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eog (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Siddhesh Poyarekar
Fedora Extras Quality Assurance
:
: 613115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 15:44 EDT by Michael Monreal
Modified: 2015-09-13 20:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: eog-2.30.1-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 03:24:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample image (8.38 KB, image/png)
2010-06-09 15:44 EDT, Michael Monreal
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 622161 None None None Never

  None (edit)
Description Michael Monreal 2010-06-09 15:44:37 EDT
Created attachment 422673 [details]
Sample image

For some time now, eog has trouble opening some image files. Not 100% sure but I think most if not all images I have trouble opening are gimp-edited screenshots in png.

What happens if I double click on such an image? Mouse pointer spins, but no window opens. If doing multiple times, an empty window opens.

I can open other pngs (backgrounds etc) just fine.
Comment 1 Michael Monreal 2010-06-09 15:51:56 EDT
I just closed all eog windows, and there is still one eog process running:

$ ps ax | grep eog
 8086 ?        Sl     0:00 eog /home/mimox/Desktop/bugs/authconfig.png

After killing this process and running 'eog /home/mimox/Desktop/bugs/authconfig.png' manually from the console, still nothing happens (terminal stays in use but no app opening)
Comment 2 Fedora Admin XMLRPC Client 2010-07-02 05:20:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Siddhesh Poyarekar 2010-08-04 08:07:56 EDT
Is the behaviour similar to bug 613115?
Comment 4 Michael Monreal 2010-08-04 09:17:47 EDT
Yes, seems to be the same issue. Also, this is still happening.

To reproduce, press "print" to save a screenshot to the desktop. I can successfully open this 20 times in a row. Open it with gimp, crop out some part and just save. Now open it again in gimp and if it works, keep closing/opening. At some point eog will fail to come up, mouse pointer spinning and nothings happens.
Comment 5 Michael Monreal 2010-11-01 11:14:05 EDT
This is still happening on F-14. I want this fixed... Best to open an upstream bug, right?
Comment 6 Michael Monreal 2010-11-01 11:24:08 EDT
Reported upstream now: https://bugzilla.gnome.org/show_bug.cgi?id=633709
Comment 7 Siddhesh Poyarekar 2010-11-02 02:25:54 EDT
(In reply to comment #6)
> Reported upstream now: https://bugzilla.gnome.org/show_bug.cgi?id=633709

Thanks. I was able to reproduce by turning on the statusbar-date plugin, so that must be the issue. I will track this with upstream bug 622161, since I believe that is the problem here.
Comment 8 Michael Monreal 2010-11-02 05:28:42 EDT
(In reply to comment #7)
> I will track this with upstream bug 622161, since I
> believe that is the problem here.

Sure. The discussion on that bug sounds like the "fix" will be a rewrite of the extension system for 3.x so 2.32.x will probably stay broken. Maybe the plugin should be excluded from the package as long as it is known to cause problems?
Comment 9 Siddhesh Poyarekar 2010-11-13 14:29:43 EST
Upstream has committed a workaround. Will backport it tomorrow.
Comment 10 Siddhesh Poyarekar 2010-11-13 14:30:12 EST
*** Bug 613115 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-12-06 14:22:26 EST
eog-2.32.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/eog-2.32.0-3.fc14
Comment 12 Fedora Update System 2010-12-06 14:26:37 EST
eog-2.30.1-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/eog-2.30.1-3.fc13
Comment 13 Fedora Update System 2010-12-07 15:10:49 EST
eog-2.30.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eog'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/eog-2.30.1-3.fc13
Comment 14 Fedora Update System 2010-12-12 15:04:11 EST
eog-2.32.0-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-12-17 03:24:27 EST
eog-2.30.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.