Bug 602505 - coverity: ldbm_back_upgradedb: upgradedb_copy_logfiles does cnt++ instead of (*cnt)++
Summary: coverity: ldbm_back_upgradedb: upgradedb_copy_logfiles does cnt++ instead of ...
Status: CLOSED DUPLICATE of bug 609590
Alias: None
Product: 389
Classification: Retired
Component: Database - General   
(Show other bugs)
Version: 1.2.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Chandrasekar Kannan
URL: http://10.16.47.145:8080/sourcebrowse...
Whiteboard:
Keywords:
Depends On:
Blocks: 434915 389_1.2.7
TreeView+ depends on / blocked
 
Reported: 2010-06-10 02:14 UTC by Noriko Hosoi
Modified: 2015-01-04 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 21:19:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noriko Hosoi 2010-06-10 02:14:16 UTC
Description of problem:
11772 ARRAY_VS_SINGLETON Triaged Bug Minor Fix Required ldbm_back_upgradedb()
File: ds/ldap/servers/slapd/back-ldbm/ldif2ldbm.c

Status:  	New  	→  	Triaged
Classification: 	Unclassified 	→ 	Bug
Action: 	Undecided 	→ 	Fix Required
Severity: 	Unspecified 	→ 	Minor

Comment:
upgradedb_copy_logfiles does cnt++ instead of (*cnt)++ but cnt is not used in that function, nor is the value of cnt used anywhere else. I think the proper fix is to just get rid of the cnt parameter to upgradedb_copy_logfiles.

Comment 2 Noriko Hosoi 2010-08-05 21:19:31 UTC

*** This bug has been marked as a duplicate of bug 609590 ***


Note You need to log in before you can comment on or make changes to this bug.