Bug 609590 - fix coverity Defect Type: Memory - corruptions issues
Summary: fix coverity Defect Type: Memory - corruptions issues
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Server   
(Show other bugs)
Version: 1.2.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
: 602505 602510 602525 834051 (view as bug list)
Depends On:
Blocks: 389_1.2.7 639035
TreeView+ depends on / blocked
 
Reported: 2010-06-30 16:29 UTC by Rich Megginson
Modified: 2015-01-04 23:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-17 14:08:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (2.88 KB, patch)
2010-06-30 21:46 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0002-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.17 KB, patch)
2010-06-30 21:46 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0003-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.11 KB, patch)
2010-06-30 21:46 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0004-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.27 KB, patch)
2010-06-30 21:47 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0005-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.46 KB, patch)
2010-06-30 21:47 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0006-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.25 KB, patch)
2010-06-30 21:48 UTC, Rich Megginson
no flags Details | Diff
0007-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.26 KB, patch)
2010-06-30 21:48 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0008-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.99 KB, patch)
2010-06-30 21:48 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0009-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1.27 KB, patch)
2010-06-30 21:49 UTC, Rich Megginson
nhosoi: review+
Details | Diff
0012-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch (1008 bytes, patch)
2010-06-30 21:49 UTC, Rich Megginson
nhosoi: review+
Details | Diff

Description Rich Megginson 2010-06-30 16:29:05 UTC
fix coverity Defect Type: Memory - corruptions issues

Comment 2 Rich Megginson 2010-06-30 21:46:16 UTC
Created attachment 428107 [details]
0001-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 3 Rich Megginson 2010-06-30 21:46:37 UTC
Created attachment 428108 [details]
0002-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 4 Rich Megginson 2010-06-30 21:46:56 UTC
Created attachment 428109 [details]
0003-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 5 Rich Megginson 2010-06-30 21:47:17 UTC
Created attachment 428110 [details]
0004-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 6 Rich Megginson 2010-06-30 21:47:40 UTC
Created attachment 428112 [details]
0005-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 7 Rich Megginson 2010-06-30 21:48:10 UTC
Created attachment 428113 [details]
0006-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 8 Rich Megginson 2010-06-30 21:48:30 UTC
Created attachment 428115 [details]
0007-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 9 Rich Megginson 2010-06-30 21:48:59 UTC
Created attachment 428116 [details]
0008-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 10 Rich Megginson 2010-06-30 21:49:22 UTC
Created attachment 428117 [details]
0009-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 11 Rich Megginson 2010-06-30 21:49:47 UTC
Created attachment 428119 [details]
0012-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

Comment 12 Noriko Hosoi 2010-07-01 18:26:09 UTC
Comment on attachment 428113 [details]
0006-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

+                    /* cannot allow pt->pt_sizendx == PLMAXSIZENDX */
Fix is good.  I guess the comment wants to say 
  cannot allow (pt->pt_sizendx + 1) == PLMAXSIZENDX
???

Comment 13 Noriko Hosoi 2010-07-01 18:26:48 UTC
Comment on attachment 428113 [details]
0006-Bug-609590-fix-coverity-Defect-Type-Memory-cor.patch

+                    /* cannot allow pt->pt_sizendx == PLMAXSIZENDX */
Fix is good.  I guess the comment wants to say 
  cannot allow (pt->pt_sizendx + 1) == PLMAXSIZENDX
???

Comment 14 Rich Megginson 2010-07-01 18:57:42 UTC
(In reply to comment #13)
> (From update of attachment 428113 [details])
> +                    /* cannot allow pt->pt_sizendx == PLMAXSIZENDX */
> Fix is good.  I guess the comment wants to say 
>   cannot allow (pt->pt_sizendx + 1) == PLMAXSIZENDX
> ???    

No, (pt->pt_sizendx + 1) == PLMAXSIZENDX is ok - we have to prevent pt->pt_sizendx == PLMAXSIZENDX

Comment 15 Rich Megginson 2010-07-06 16:31:13 UTC
To ssh://git.fedorahosted.org/git/389/ds.git
   e4ca30c..830d55e  master -> master
commit 830d55e8cc9d4a69f099b1c0ee00a93817c8fabb
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:51:18 2010 -0600
commit a9a5a5d9fe0801988f51a77b4b11029349f67c10
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:40:34 2010 -0600
commit 8401a419da225ade87aa6f36f4b35bafce629c8a
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:35:16 2010 -0600
commit 138daaa4b171b770e0372c19fb5f656309eea4b1
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:18:36 2010 -0600
commit d76bdddeb292b1d71e5d7b1dcdcd985d39025a15
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:15:37 2010 -0600
commit c1a89263495c933673f8b977f6c202f34e65b293
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 14:08:55 2010 -0600
commit fc16d51c7349b07a405085fd80548a6d0aaf31e8
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 13:28:39 2010 -0600
commit 6098df0ea1aec1c25334b4229fe196ca02c0fc26
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 11:37:34 2010 -0600
commit 858f45f80fa73367bc5cf18b3dd29e3129fbe70c
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 11:23:33 2010 -0600
commit 4739bf587db66c9d8ceabd446dabbe03bc3a0664
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 10:52:05 2010 -0600
commit fabd35294d0159ca840b019b6108df2eb759fea3
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 10:46:52 2010 -0600
commit 99fa0c1363c32a2e3352c07be4b5aae751018d23
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 10:43:20 2010 -0600

Comment 16 Noriko Hosoi 2010-08-05 21:19:31 UTC
*** Bug 602505 has been marked as a duplicate of this bug. ***

Comment 17 Noriko Hosoi 2010-08-05 21:20:50 UTC
*** Bug 602510 has been marked as a duplicate of this bug. ***

Comment 19 Noriko Hosoi 2012-07-09 22:46:24 UTC
*** Bug 602525 has been marked as a duplicate of this bug. ***

Comment 20 Noriko Hosoi 2012-07-09 22:47:45 UTC
*** Bug 834051 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.