Bug 602510 - coverity: usn_cleanup_thread: could try to free static memory
Summary: coverity: usn_cleanup_thread: could try to free static memory
Keywords:
Status: CLOSED DUPLICATE of bug 609590
Alias: None
Product: 389
Classification: Retired
Component: Server - Plugins
Version: 1.2.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Chandrasekar Kannan
URL: http://10.16.47.145:8080/sourcebrowse...
Whiteboard:
Depends On:
Blocks: 434915 389_1.2.7
TreeView+ depends on / blocked
 
Reported: 2010-06-10 02:21 UTC by Noriko Hosoi
Modified: 2015-01-04 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-05 21:20:50 UTC


Attachments (Terms of Use)

Description Noriko Hosoi 2010-06-10 02:21:28 UTC
Description of problem:
11774 BAD_FREE Triaged Bug Minor Fix Required usn_cleanup_thread()
File: ds/ldap/servers/plugins/usn/usn_cleanup.c

Status:  	New  	→  	Triaged
Classification: 	Unclassified 	→ 	Bug
Action: 	Undecided 	→ 	Fix Required
Severity: 	Unspecified 	→ 	Minor

Comment:
The only way to do the invalid free of static memory is if the plugin is uninitialized. This is very unlikely, if not impossible, to happen.

Comment 2 Noriko Hosoi 2010-08-05 21:20:50 UTC

*** This bug has been marked as a duplicate of bug 609590 ***


Note You need to log in before you can comment on or make changes to this bug.