Bug 602525 - coverity: main: negative return value from "read" is not handled correctly
Summary: coverity: main: negative return value from "read" is not handled correctly
Status: CLOSED DUPLICATE of bug 609590
Alias: None
Product: 389
Classification: Retired
Component: Command Line Utilities   
(Show other bugs)
Version: 1.2.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Chandrasekar Kannan
URL: http://10.16.47.145:8080/sourcebrowse...
Whiteboard:
Keywords:
Depends On:
Blocks: 389_1.3.0
TreeView+ depends on / blocked
 
Reported: 2010-06-10 03:42 UTC by Noriko Hosoi
Modified: 2015-01-04 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 22:46:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noriko Hosoi 2010-06-10 03:42:26 UTC
Description of problem:
11956 NEGATIVE_RETURNS Triaged Bug Minor Fix Required main()
File: ds/ldap/servers/slapd/tools/ldif.c

Status:  	New  	→  	Triaged
Classification: 	Unclassified 	→ 	Bug
Action: 	Undecided 	→ 	Fix Required
Severity: 	Unspecified 	→ 	Minor

Comment:
minor problem in the ldif tool - no fix required for 8.2 because this is in a seldom used command line tool.

Comment 3 Martin Kosek 2012-01-04 13:31:34 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/85

Comment 4 Noriko Hosoi 2012-07-09 22:46:24 UTC

*** This bug has been marked as a duplicate of bug 609590 ***


Note You need to log in before you can comment on or make changes to this bug.