Bug 603364 - New update to JDK breaks Applet plugin
New update to JDK breaks Applet plugin
Status: CLOSED DUPLICATE of bug 602906
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 12:01 EDT by Gerard Fernandes
Modified: 2010-06-14 08:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 08:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2010-06-12 12:01:28 EDT
Description of problem: New update to JDK breaks Applet plugin


Version-Release number of selected component (if applicable):
[gerry@achiles ~]$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (fedora-39.b18.fc13-i386)
OpenJDK Client VM (build 14.0-b16, mixed mode)


How reproducible: Always


Steps to Reproduce:
1. Open browser (Firefox in this case, as Epiphany obviously doesn't like Java anyway).
2. Navigate to http://www.java.com/en/download/help/testvm.xml
3. Observe no Java
4. Confirm this by typing "about:plugins" in the location bar in Firefox - observe there are no registered Java plugins.
  
Actual results: No Java plugins seem to be registered after this recent JDK update.

Expected results: There should be a Java applet plugin registered


Additional info: Running alternatives provides the following information:
[gerry@achiles ~]$ alternatives --config libjavaplugin.so

There are 2 programs which provide 'libjavaplugin.so'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaNPPlugin.so
   2           /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaPlugin.so

Workaroud:
Switch to the 2nd plugin above and restart Firefox. This makes the Java applet plugin work in Firefox again.

[gerry@achiles ~]$ alternatives --display libjavaplugin.so
libjavaplugin.so - status is manual.
 link currently points to /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaPlugin.so
/usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaNPPlugin.so - priority 16000
/usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaPlugin.so - priority 16000
Current `best' version is /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaNPPlugin.so.
Comment 1 Martin Matejovic 2010-06-14 08:12:39 EDT

*** This bug has been marked as a duplicate of bug 602906 ***

Note You need to log in before you can comment on or make changes to this bug.