Bug 602910 - mouse is lethargic and gnome mouse control doesn't speed it up
mouse is lethargic and gnome mouse control doesn't speed it up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Triaged
: 621591 621919 625966 627594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 21:07 EDT by darrell pfeifer
Modified: 2010-09-01 01:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-01 01:51:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2010-06-10 21:07:34 EDT
Description of problem:

After installing the new driver the mouse moves at the slowest and most lethargic speed possible. Changing the gnome mouse control panel does nothing. Reverting to the previous release fixes problem.

Version-Release number of selected component (if applicable):

1.2.99-1.20100601.fc14

1.2.2-6.fc14 (old driver that works)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Hutterer 2010-06-10 23:05:41 EDT
fwiw, http://who-t.blogspot.com/2010/06/new-synaptics-acceleration-mechanism.html
there's some more patches in the pipe though.
Comment 2 Peter Hutterer 2010-06-18 00:51:16 EDT
pushed out another update yesterday, does it work better now?
Comment 3 darrell pfeifer 2010-06-18 00:59:07 EDT
I tried it yesterday and reverted right away. It works about the same as the previous version.

On my 1900x1200 laptop, it takes 10+ full swipes across pad to move the mouse across the screen. Normally I have it set to go across in about one swipe, so for me it is pretty much unusable.
Comment 4 Stijn Hoop 2010-07-19 13:56:38 EDT
I see the same problem after a "fresh" rawhide install (which was done by first installing F13 release + updates, then doing yum update).

synclient -l | grep AccelFactor gave me

    AccelFactor             = 0.0105352

which seemed a bit low.

Indeed, setting it to 2 "fixes" the problem, that is, it is usable now (although a bit fast).

This exact same laptop had good settings out of the box on Fedora 12 (by which I hope you can restore that same behaviour).

Dell D620 laptop, ALPS touchpad.

Hopefully relevant Xorg lines:

[    38.388] (II) Synaptics touchpad driver version 1.2.99.1
[    38.388] (**) Option "Device" "/dev/input/event5"
[    38.397] (--) AlpsPS/2 ALPS DualPoint TouchPad: x-axis range 0 - 1023
[    38.397] (--) AlpsPS/2 ALPS DualPoint TouchPad: y-axis range 0 - 767
[    38.397] (--) AlpsPS/2 ALPS DualPoint TouchPad: pressure range 0 - 127
[    38.397] (--) AlpsPS/2 ALPS DualPoint TouchPad: finger width range 0 - 0
[    38.397] (--) AlpsPS/2 ALPS DualPoint TouchPad: buttons: left right middle
[    38.405] (--) AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    38.405] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    38.409] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD)
[    38.409] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    38.409] (**) AlpsPS/2 ALPS DualPoint TouchPad: MaxSpeed is now 1.7
[    38.409] (**) AlpsPS/2 ALPS DualPoint TouchPad: AccelFactor is now 0.0
[    38.410] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
[    38.410] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 1
[    38.410] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
[    38.410] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
[    38.417] (--) AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    38.420] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
[    38.420] (II) No input driver/identifier specified (ignoring)

RPM version: xorg-x11-drv-synaptics-1.2.99.1-3.20100617.fc14.x86_64
Comment 5 Bug Zapper 2010-07-30 08:05:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Peter Hutterer 2010-08-19 00:38:25 EDT
*** Bug 621591 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Bierfert 2010-08-19 08:24:57 EDT
*** Bug 621919 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Bierfert 2010-08-19 08:34:39 EDT
Same AccelFactor here. I tried increasing it to 2 but even that felt a little slow. I downgraded to xorg-x11-drv-synaptics-1.2.2-6.fc14 and everything is working well (including scrolling as described in bug #621919).
Even so the blog entry sounds nice, letting f14 ship with the current defaults is a major step back in usability.
Comment 9 Peter Hutterer 2010-08-19 18:17:58 EDT
how does this one feel like?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2413313
Comment 10 darrell pfeifer 2010-08-19 18:45:41 EDT
I was the original reporter, but don't think I can test this at the moment. The last working intel driver and x server combo for me is

xorg-x11-drv-intel.x86_64 2.12.0-4.fc14
xorg-x11-server-Xorg.x86_64 1.8.0-7.fc14
Comment 11 Peter Hutterer 2010-08-22 18:29:51 EDT
*** Bug 625966 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Fenzi 2010-08-22 19:47:05 EDT
The package from comment 9 works much much better here. 

I installed f14 and ran into the same issue with my 1920x1280 monitor. Very very slow. 
The package in comment 9 seems to fix it all up here.
Comment 13 Fedora Update System 2010-08-22 20:17:23 EDT
xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14
Comment 14 Andreas Bierfert 2010-08-23 06:49:05 EDT
xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14 seems to fix this for me as well.
Comment 15 darrell pfeifer 2010-08-23 09:59:22 EDT
I'm using the latest out of rawhide (so 1.2.99.901-1.20100823.fc15)

It is usable, but not great.

It takes 3 or 4 full swipes across the pad to get all the way across the screen. I would normally have the acceleration set to get all way across in one swipe. I'm sure this is going to be a matte of taste, until the mouse control panel is hooked up again.
Comment 16 Fedora Update System 2010-08-23 15:03:39 EDT
xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-synaptics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14
Comment 17 Peter Hutterer 2010-08-23 17:50:34 EDT
(In reply to comment #15)
> It is usable, but not great.

I agree, but unfortunately this bug got pre-empted by a million other bugs. I'm hoping to get this resolved over the next cycle. One of the issues I noticed is that the acceleration is quite bad when an external monitor is connected too.
Comment 18 Adam Jackson 2010-08-27 11:36:59 EDT
*** Bug 627594 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2010-09-01 01:51:40 EDT
xorg-x11-drv-synaptics-1.2.99.1-4.20100819.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.