Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602985 - 'Request-URI Too Large'
'Request-URI Too Large'
Status: CLOSED DUPLICATE of bug 820079
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.6
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 03:54 EDT by Petr Šabata
Modified: 2014-10-12 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 00:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šabata 2010-06-11 03:54:23 EDT
Description of problem:
The Red Hat's Bugzilla repeatedly reports the 'Request-URI Too Large' HTTP error whenever I try to work with a larger set of components.

Version-Release number of selected component (if applicable):
3.4.6+

How reproducible:
Always

Steps to Reproduce:
1. Navigate to bugzilla.redhat.com
2. Choose 'Search', 'Advanced search'
3. Choose 'Classification: Fedora', 'Product: Fedora', refresh components, 
select all Perl packages (perl*) in the Components list.
4. Search
5. Try to 'Remember search' or sort the resulting list of bugs.
  
Actual results:
'Request-URI Too Large' HTTP error.

Expected results:
'Remember search' feature or sorting working.

Additional info:
-
Comment 1 David Lawrence 2010-06-14 17:37:22 EDT
The web server itself is configured to a specific limit for URI length. We are not able to change that value. We ask people who need to use long queries to either do it via XMLRPC which uses POST so therefore has no limit, or to run it from query.cgi which will not convert to URI if the length is over the limit. Problem with the latter is that you cannot create a bookmark or stored search from the search.

Bugzilla will have to be fixed upstream to allow workarounds for this type of problem as not many installations have as many components as we do.

As for your issue, if you are just searching for components with "perl-*" in the name, then instead of selecting all of the components from the list, you can specify a regex using the boolean charts. Do the rest of your query the same way except for the component portion, enter in the boolean charts section at the bottom:

"Component" "regexp" "^perl-"

and that will do the same thing.

Dave
Comment 2 Petr Šabata 2010-06-15 02:33:47 EDT
Dave, thank you for the explanation. The RE search solves it for me.
Comment 3 Jeff Fearn 2012-05-30 00:43:17 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 4 Petr Šabata 2012-05-30 04:11:33 EDT
Although I don't get hit by this, it still keeps happening.
Comment 5 Simon Green 2012-06-20 00:00:24 EDT

*** This bug has been marked as a duplicate of bug 820079 ***

Note You need to log in before you can comment on or make changes to this bug.