Bug 820079 - Cannot view dependent bugs when there are many
Cannot view dependent bugs when there are many
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Dependency Views (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
: 599180 602985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 01:51 EDT by Simon Green
Modified: 2014-10-12 18:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.2.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-16 23:24:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Green 2012-05-09 01:51:06 EDT
Description of problem:
the RHEL 6.3 Priority List:
https://bugzilla.redhat.com/show_bug.cgi?id=756082

If I click on 'Show dependency tree', the total is 1734 bugs. If I click
on 'view bug list' I get, consistently:
"Request-URI Too Large
The requested URL's length exceeds the capacity limit for this server.
Apache Server at bugzilla.redhat.com Port 443"

Version-Release number of selected component (if applicable):
3.6

How reproducible:
Always

Steps to Reproduce:
1. Log in.
2. Visit https://bugzilla.redhat.com/showdependencytree.cgi?id=756082&hide_resolved=1
3. Click 'View as bug list'
  
Actual results:
You receive a HTTP 414 error (request too large)

Expected results:
You should see a list of bugs.

Additional info:
This is a result of the limit that a URL can be. We'll need to look up the HTTP standards to see what that is. I imagine the solution is to turn this into a POST request, but that means the URL is not bookmark.

There may be other options, like doing a search that includes deep dependency fetching.
Comment 1 Simon Green 2012-05-09 20:42:25 EDT
*** Bug 599180 has been marked as a duplicate of this bug. ***
Comment 3 Simon Green 2012-06-08 01:46:58 EDT
While I have made the change on our test server (see comment #2), I have submitted this bug upstream and hope that they will carry this, or offer an alternative.

  -- simon
Comment 6 Simon Green 2012-06-14 02:23:18 EDT
Marking as ON_DEV as I'm waiting for upstream to approve my patch. If they approve it for 4.2, then we'll inherit the change that way. If they wait for 4.4, then we'll carry the changes locally.
Comment 7 Simon Green 2012-06-20 00:00:24 EDT
*** Bug 602985 has been marked as a duplicate of this bug. ***
Comment 9 Simon Green 2012-07-09 03:25:37 EDT
This change is due to go live at 9pm UTC today (Monday July 9th)

  -- simon
Comment 10 Simon Green 2012-07-09 17:02:00 EDT
The release date has been changed to 9pm UTC this Thursday (July 12th). Sorry for any inconvenience this late change may cause.

  -- simon
Comment 13 Simon Green 2013-04-16 23:24:58 EDT
Do not reopen a bug for a previous release, as I will automatically close it again. Please file a new bug. FWIW, the link in comment #11 works for me.

Note You need to log in before you can comment on or make changes to this bug.