Bug 603164 - anaconda bombs during preupgrade installation
anaconda bombs during preupgrade installation
Status: CLOSED DUPLICATE of bug 597895
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 13:53 EDT by thumbtack
Modified: 2010-06-11 14:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 14:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report generated by anacona when it bombed (270.33 KB, application/octet-stream)
2010-06-11 13:53 EDT, thumbtack
no flags Details

  None (edit)
Description thumbtack 2010-06-11 13:53:18 EDT
Created attachment 423351 [details]
bug report generated by anacona when it bombed

Description of problem:  Ran preupgrade on Fedora 11 x86_64 installation; image was too big, but internet connection was available; have dual boot system on two disks; disk 1 has Linux; disk2 has Vista; disk2 has the master boot record.  Started the installation, found the old Fedora 11, found the master boot record on the other disk, but when asked to update the old mbr, it bombed, generating the attached report


Version-Release number of selected component (if applicable): current anaconda which comes with the Fedora 13 distribution


How reproducible:  Did it twice


Steps to Reproduce:
1.  run preupgrade
2.  when told that image is too big for old /boot (200 MB), told it to use the internet connection; it started anaconda
3.  anaconda came up with three disks (two internal, one external used for backups)
    selected the correct disk, the one with Fedora 11 on it
4.  Next screen asked how to handle the mbr.  Recommended course of action
    was to update the old mbr; I left that checked, and hit next.  NOTE: the old mbr was on the second internal hard drive, the one containing Vista.
  
Actual results: it bombed with the attached bug report


Expected results: it should have started to do the upgrade, which I eventually did using a Fedora 13 disk, and (this may be important) telling it to create a new mbr on the hard disk that contained Fedora 11  (in other words, I killed
the old dual boot, although by changing the boot disk priority, I could still bring up Vista if I wanted to do so).


Additional info: See attached bug report
Comment 1 Chris Lumens 2010-06-11 14:09:37 EDT

*** This bug has been marked as a duplicate of bug 597895 ***

Note You need to log in before you can comment on or make changes to this bug.