Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 603265 - system-config-users errors on deleting user
system-config-users errors on deleting user
Status: CLOSED DUPLICATE of bug 602192
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 01:50 EDT by Bruce Brackbill
Modified: 2010-06-14 04:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 04:55:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-users Delete User Dialog (31.33 KB, image/png)
2010-06-12 01:50 EDT, Bruce Brackbill
no flags Details

  None (edit)
Description Bruce Brackbill 2010-06-12 01:50:59 EDT
Created attachment 423440 [details]
system-config-users Delete User Dialog

Description of problem:

When I attempt to delete a user with system-config-users the dialog comes up and I press yes and the following error appears in the console.

[root@localhost ~]# system-config-users
Traceback (most recent call last):
  File "/usr/share/system-config-users/mainWindow.py", line 710, in on_delete_activate
    self.rmrf(mailSpool)
  File "/usr/share/system-config-users/mainWindow.py", line 890, in rmrf
    raise
TypeError: exceptions must be classes or instances, not NoneType
[root@localhost ~]# 

The user's home directory IS deleted but the only way to close the dialog is to X out of it.

The user frank still exists and when I bring up the Delete dialog again the dialog is different saying: "I won't delete frank <snip> direcory does not exist".  ( See attached image ).  This dialog successfully closes and The user frank is deleted. 

system-config-users-1.2.98-1.fc13.noarch and everything updated.  Testing repo enabled.
Comment 1 Nils Philippsen 2010-06-14 04:55:35 EDT
I've already fixed this and issued an update but it hasn't been pushed to testing yet.

*** This bug has been marked as a duplicate of bug 602192 ***

Note You need to log in before you can comment on or make changes to this bug.