Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603358 - [abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
[abrt] crash in epiphany-2.30.2-1.fc13: malloc_consolidate: Process /usr/bin/...
Status: CLOSED DUPLICATE of bug 615502
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:8525a6a6ba590656a0e74e9a4c3...
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 11:10 EDT by Illya
Modified: 2010-08-10 19:50 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 19:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (52.33 KB, text/plain)
2010-06-12 11:10 EDT, Illya
no flags Details
Backtrace with deactivated java-script/plugins (47.15 KB, text/plain)
2010-08-09 15:24 EDT, Illya
no flags Details
Epiphany and jaba (41.35 KB, text/plain)
2010-08-09 16:44 EDT, Peter Robinson
no flags Details
epiphany gmail backtrace (10.11 KB, application/x-gzip)
2010-08-09 17:29 EDT, Chad Feller
no flags Details
Settings (33.33 KB, image/png)
2010-08-10 17:27 EDT, Illya
no flags Details

  None (edit)
Description Illya 2010-06-12 11:10:24 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: epiphany
component: epiphany
crash_function: malloc_consolidate
executable: /usr/bin/epiphany
global_uuid: 8525a6a6ba590656a0e74e9a4c37f3608cad1b9f
kernel: 2.6.33.5-112.fc13.x86_64
package: epiphany-2.30.2-1.fc13
rating: 4
reason: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Browser starten
2. www.lufthansa.com open
3.
Comment 1 Illya 2010-06-12 11:10:27 EDT
Created attachment 423522 [details]
File: backtrace
Comment 2 Iván Jiménez 2010-06-17 11:29:51 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Go to semana.com

Comment
-----
Visit semana.com web page and epiphany crash, it doesn't crash in firefox.
Comment 3 Mihai Harpau 2010-06-18 07:36:01 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
I tried to start epiphany
Comment 4 Peter Robinson 2010-06-18 14:38:42 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start epiphany
2.
3.
Comment 5 Iván Jiménez 2010-06-23 14:00:21 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Go to www.ingeominas.gov.co
2.
3.
Comment 6 Chad Feller 2010-06-23 17:14:55 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open epiphany
2. go to youtube.com
3.
Comment 7 Rob Wills 2010-06-25 00:19:06 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. go to http://acid3.acidtests.org/ from within epiphany
2. observe browser crash
3.


Comment
-----
Was going to the Acid 3 test site to see how well epiphany would perform against firefox and chrome.
Comment 8 Chad Feller 2010-06-25 15:50:43 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open epiphany
2. go to gmail login page
3.
Comment 9 Daniel 2010-06-26 16:18:55 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. In epiphany, open http://friendfeed.com/mbauwens/3108a1d2/ripplexchange-view-topic-donation-pool-ripple


Comment
-----
Seems consistently reproducible.
Comment 10 Rob Wills 2010-06-27 23:53:38 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open epiphany
2. go to a website
3. crash


Comment
-----
I was going to the acid 3 test page when this crash happened.
Comment 11 Jan Debertshäuser 2010-07-01 16:09:38 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just crashed right after starting.
Comment 12 MERCIER Jonathan 2010-07-02 12:41:00 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. frquently when i click on linck here: http://blogs.unity3d.com/2010/07/02/unity-and-ios-4-0-update-iii/
2. Crash
Comment 13 Andreas Tunek 2010-07-09 10:45:37 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to slashdot.org
Comment 14 Andreas Tunek 2010-07-09 10:47:25 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to slashdot.org
Comment 15 Andreas Tunek 2010-07-09 10:49:23 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to youtube
Comment 16 Andreas Tunek 2010-07-09 11:41:02 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to youtube
Comment 17 Simon Dwyer 2010-07-12 22:32:51 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.enable plugins 
2.restart browser
3.go to any flash page


Comment
-----
Enabling plugins and viewing a flash site crashes the browser.

The backtrace above says permission denied but 

bash-4.1$ pwd
/home/sdwyer/.mozilla/plugins
bash-4.1$ ls -l
total 9348
-rwxr-xr-x. 1 sdwyer sdwyer 9570824 Jun  1 08:15 libflashplayer.so

shows that my user owns it and anyone can x anyway.
Comment 18 Andreas Tunek 2010-07-14 17:43:44 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to youtube.com
Comment 19 David Le Sage 2010-07-15 20:14:03 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Crashes on launch.  

Comment
-----
Crashes on launch.
Comment 20 David Le Sage 2010-07-15 20:24:20 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Crash on launch, even after removing all old settings, in case it was a problem with them.
Comment 21 David Le Sage 2010-07-15 21:23:34 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Crashed going to bookmarked page.
Comment 22 Andreas Tunek 2010-07-16 09:05:22 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Go to youtube
Comment 23 Andreas Tunek 2010-07-25 05:41:28 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Went  to kotaku.com
Comment 24 Amit Shah 2010-07-26 01:58:24 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start epiphany
2. Go to http://lwn.net (maybe login is needed)
3. Crash (or, visit the kernel or front page of the Jul 22 2010 page -- crash.)
Comment 25 Scott Worley 2010-07-26 21:21:33 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start ephinany with homepage www.google.com
2. Enter search terms: fedora 13 32-bit firefox
3. 3rd or 4th result is a link to fedora unity forum, click link and browser crashes before page begins to load.
Comment 26 d. johnson 2010-08-09 10:23:37 EDT
Unfortunately, crash here happened in the binary-only flash player for which we don't have any source code, so unfortunately we cannot help you with it.

Closing as CANTFIX (because that's our situation)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Peter Robinson 2010-08-09 10:30:29 EDT
(In reply to comment #26)
> Unfortunately, crash here happened in the binary-only flash player for which we
> don't have any source code, so unfortunately we cannot help you with it.
> 
> Closing as CANTFIX (because that's our situation)

Its not just the binary flash component that causes this. Install the full open source java plugin, or gnash, or lightspark. All cause the problem and all are open source. I don't have (nor ever have had) the binary only flash player installed on this machine. So fortunately now you can help :-)
Comment 28 d. johnson 2010-08-09 12:36:25 EDT
Peter, Please open a new bug report that has your information in it.

This bug report was using flash, and did crash because of it.

When you do open your report, be sure that you have run "yum update" as root and restarted to ensure that you have all current updates applied.

Next, disable extensions, plugins and non-default themes. Clear cookies and cache. Exit the browser completely.  Then restart the browser and attempt to replicate the crash.

If you are unable to reproduce the same bug with plugins disabled, then add them one at a time until you are able to do so.  It may be a bug in the plugin rather than the browser.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Chad Feller 2010-08-09 14:04:57 EDT
(In reply to comment #27)

> Its not just the binary flash component that causes this. Install the full open
> source java plugin, or gnash, or lightspark. All cause the problem and all are
> open source. I don't have (nor ever have had) the binary only flash player
> installed on this machine. So fortunately now you can help :-)    

I second this.  I don't have the binary player, but rather gnash installed and my crashes were marked as a clone of the original.
Comment 30 Andreas Tunek 2010-08-09 14:10:38 EDT
Yeah, java crashes will be reported as dupes. Are the dupes saved? If so, just take a look at them.
Comment 31 Peter Robinson 2010-08-09 14:14:11 EDT
(In reply to comment #28)
> Peter, Please open a new bug report that has your information in it.
> 
> This bug report was using flash, and did crash because of it.

And abrt has identified 25 duplicates of this that have the same crash that weren't necrophilia flash (well mine wasn't and I can submit the other 25 identical in my abrt queue that I don't both to report as they'd be identified as a dupe). 

> When you do open your report, be sure that you have run "yum update" as root
> and restarted to ensure that you have all current updates applied.

Please. I run constantly up to date updates-testing so that doesn't apply.

> Next, disable extensions, plugins and non-default themes. Clear cookies and
> cache. Exit the browser completely.  Then restart the browser and attempt to
> replicate the crash.

Its easy to replicate.... install any of the open source or non open source plugins including but not limited to (install any single one or them all, it makes no difference):
- gnash
- java - the iced tea open version
- lightspark - http://bugzilla.rpmfusion.org/show_bug.cgi?id=1313 

> If you are unable to reproduce the same bug with plugins disabled, then add
> them one at a time until you are able to do so.  It may be a bug in the plugin
> rather than the browser.

It works fine with NO plugins installed what so ever. As soon as I install any plugin (see above) it produces the crash which is de-duped by abrt as this bug. So somehow I don't think its a single plugin
Comment 32 d. johnson 2010-08-09 14:57:31 EDT
Chad, Andreas, Peter - If one of you could kindly include the crash report that may help.  So far, the only one does not appear to match what you are reporting.

Peter, if you are using unreleased, or unofficial packages, you will certainly need to use a different bug report.

I have many plugins installed, and with the information provided in this report, I am unable to reproduce your bug.  Please be specific, and provide the crash report matching your crash.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 33 Illya 2010-08-09 15:24:10 EDT
Created attachment 437688 [details]
Backtrace with deactivated java-script/plugins

Hi.

I have disabled plugins and java-script im settings, but it doesn't help. Epiphany crashes in 5 seconds at www.lufhansa.com.
Comment 34 Andreas Tunek 2010-08-09 15:33:20 EDT
(In reply to comment #32)

> I have many plugins installed, and with the information provided in this
> report, I am unable to reproduce your bug.  Please be specific, and provide the
> crash report matching your crash.
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers    

It only happens on 64-bit machines. Do you run 32-bit?
Comment 35 Andreas Tunek 2010-08-09 15:49:38 EDT
Tried to upload same abr, but got new bug: https://bugzilla.redhat.com/show_bug.cgi?id=622582
Comment 36 Peter Robinson 2010-08-09 16:24:27 EDT
(In reply to comment #32)
> Chad, Andreas, Peter - If one of you could kindly include the crash report that
> may help.  So far, the only one does not appear to match what you are
> reporting.
> 
> Peter, if you are using unreleased, or unofficial packages, you will certainly
> need to use a different bug report.

Two official, the unofficial was a test I was trying for other free flash support that was removed. All the same result.

> I have many plugins installed, and with the information provided in this
> report, I am unable to reproduce your bug.  Please be specific, and provide the
> crash report matching your crash.

32 or 64 bit OS?

I'll reinstall java and gnash and add them to the report manually.
Comment 37 Peter Robinson 2010-08-09 16:44:01 EDT
Created attachment 437704 [details]
Epiphany and jaba

This is epiphany with just java. Epiphany was running perfectly fine (no plugins) then I installed 1:java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.x86_64 and restarted epiphany and got the following crash.
Comment 38 Chad Feller 2010-08-09 17:05:02 EDT
(In reply to comment #34)

> 
> It only happens on 64-bit machines. Do you run 32-bit?    

I noticed this.  It happens on both of my 64-bit workstation (both F13), but I can't think of once that it crashed on my laptop (32-bit, also F13).
Comment 39 Chad Feller 2010-08-09 17:25:19 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. went to the gmail login page
2.
3.


Comment
-----
went to the gmail login page, epiphany crashed before the page finished loading
Comment 40 Chad Feller 2010-08-09 17:27:07 EDT
(In reply to comment #32)
> Chad, Andreas, Peter - If one of you could kindly include the crash report that
> may help.

Epiphany just crashed again.  For giggles, I told abrt to report the crash, and it again reported it as a duplicate of this.

I'll attached the actual backtrace following this.
Comment 41 Chad Feller 2010-08-09 17:29:44 EDT
Created attachment 437710 [details]
epiphany gmail backtrace

Here is the backtrace from epiphany attempting to load the gmail login page.
Comment 42 d. johnson 2010-08-09 22:37:22 EDT
In #33, you have several additional plugins installed: Flash, totem, rhythmbox, as well as openjdk (which sounds like it may be the real issue here).  Please disable/remove the others and try with only a single plugin.


In #37, you have a nasty bug report there.  You also have plugins: totem, rhythmbox and openjdk.

$1 = 0x218f060 "*** glibc detected *** epiphany: free(): invalid pointer: 0x0000000002180890 ***\n"

#3  0x000000309bc75676 in malloc_printerr (action=3, 
    str=0x309bd41a45 "free(): invalid pointer", ptr=<value optimized out>)
    at malloc.c:6283
        buf = "0000000002180890"
        cp = <value optimized out>
#4  0x000000309d85c4b5 in IA__g_strfreev (str_array=0x2180740)
    at gstrfuncs.c:2558
        i = <value optimized out>
#5  0x00007f6196fc519b in plugin_test_appletviewer (
    browserTable=<value optimized out>, pluginTable=<value optimized out>)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1517
        error = 0
        command_line = {
          0x21c6bf0 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/../../bin/java", 0x2222d80 "-version", 0x0}
        environment = 0x2180740
#6  NP_Initialize (browserTable=<value optimized out>, 
    pluginTable=<value optimized out>)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:2156
        np_error = 0
        filename = 0x2197af0 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64"
        info = {
          dli_fname = 0x219fd30 "/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so", dli_fbase = 0x7f6196fb9000, 
          dli_sname = 0x7f6196fbc4bb "_Z8ITNP_NewPcP4_NPPtsPS_S2_P12_NPSavedData", dli_saddr = 0x7f6196fc76e0}
        filename_size = <value optimized out>


In #41, You are missing more than a few debuginfo's.  You do appear to have mediaplayer, rhythmbox, gnash, and openjdk plugins.


If someone could reproduce this with only epiphany + openjdk plugin, and then provide "rpm -qa epiphany\* java\*" output along with a nice backtrace that would be wonderful.

(The common thread here appears to be openjdk, so please remove all other plugins so we can verify this is the case.)
Comment 43 Chad Feller 2010-08-10 00:50:58 EDT
(In reply to comment #42)
> In #41, You are missing more than a few debuginfo's.  You do appear to have
> mediaplayer, rhythmbox, gnash, and openjdk plugins.
> 
Sorry about that - just did a debuginfo-install epiphany, which satisfied abrt.  I'll take another shot at this when I get back to the office.
Comment 44 Illya 2010-08-10 17:27:42 EDT
Created attachment 438009 [details]
Settings

#42 plugins are disabled (see screenshot)
Comment 45 Evert Verhellen 2010-08-10 17:42:59 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start Epiphany.
2. Go to: http://www.delijn.be/
3. Click on "REISINFORMATIE".
4. Crash.

Comment
-----
I have both the "OpenJDK Web Browser Plugin" (java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.x86_64) and the "Web-client flash movie player plugin" (gnash-plugin-0.8.7-1.fc13.x86_64) installed. I have disabled plugins in Epiphany because of earlier crashes, to no avail unfortunately. With plugins enabled, I cannot even click on REISINFORMATIE, it crashes when the mouse pointer reaches that area of the page. In Firefox (firefox-3.6.7-1.fc13.x86_64), the web pages load without any issues.
Comment 46 d. johnson 2010-08-10 19:07:13 EDT
Illya- Sounds like you have a case for another bug report then.  Your backtrace indicates that you are actually loading the plugins listed above.

Evert- Unfortunately, that will not help much.  If the bug is between epiphany and openjdk, we need someone that has those and those only.  If you are loading additional plugins it will not help debugging.  Additionally, the versions of both packages along with the backtrace would likely help immensely.

Adding "me too" comments is not going to work if everyone has a different set of configurations.  The best and most expedient way to resolve this problem is to isolate it down to just one package.  At the moment, I'm hoping someone can provide a backtrace using *only* epiphany and openjdk, with no other extensions loading.

If that crashes, and we have a usable backtrace, we will have a nicely isolated case that we can direct accordingly.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 47 Juan P. Daza P. 2010-08-10 19:35:14 EDT
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open www.lufthansa.com



Comment
-----
crashes
Comment 48 d. johnson 2010-08-10 19:50:07 EDT
Common faulting with bug 615502.

Seems specific versions of openjdk affect all WebKit based browsers.

*** This bug has been marked as a duplicate of bug 615502 ***

Note You need to log in before you can comment on or make changes to this bug.