Bug 615502 - Instant crash webkit enabled konqueror using java-1.6.0-openjdk-1.6.0.0-41.b18.fc13 java-1.6.0-openjdk-1.6.0.0-40.b18.fc13
Summary: Instant crash webkit enabled konqueror using java-1.6.0-openjdk-1.6.0.0-41.b1...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 598254 601409 603358 605612 606177 606186 606207 606985 607013 607206 607363 607391 607992 608026 608037 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-16 20:52 UTC by Garry Reisky
Modified: 2011-06-29 13:24 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-29 13:24:09 UTC


Attachments (Terms of Use)
Backtrace (12.07 KB, text/plain)
2010-07-16 20:53 UTC, Garry Reisky
no flags Details
Epiphany crash (25.59 KB, text/plain)
2010-08-14 13:25 UTC, Evert Verhellen
no flags Details
Tail of .xsession-errors after verifying Java version at http://www.java.com (1.11 KB, text/plain)
2011-02-11 21:28 UTC, Joachim Frieben
no flags Details

Description Garry Reisky 2010-07-16 20:52:51 UTC
Description of problem:

java-1.6.0-openjdk-1.6.0.0-41.b18.fc13/java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13  java-1.6.0-openjdk-1.6.0.0-40.b18.fc13/java-1.6.0-openjdk-plugin-1.6.0.0-40.b18.fc13 crash konqueror with webkit renderer

Falling back to using java-1.6.0-openjdk-1.6.0.0-39.b18.fc13 makes webkit konqueror stable.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Browse to digg.com. Crash konqueror with webkit.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Garry Reisky 2010-07-16 20:53:44 UTC
Created attachment 432496 [details]
Backtrace

Comment 2 Garry Reisky 2010-07-16 21:00:53 UTC
I should have said in the original report that java-1.6.0-openjdk-1.6.0.0-39.b18.fc13.i686.rpm/java-1.6.0-openjdk-plugin-1.6.0.0-39.b18.fc13.i686.rpm crashes konqueror webkit

Stable version is ...  java-1.6.0-openjdk-1.6.0.0-38.b18.fc13.i686.rpm/
java-1.6.0-openjdk-plugin-1.6.0.0-38.b18.fc13.i686.rpm

Comment 3 Rex Dieter 2010-07-18 20:08:49 UTC
Confirmed, affects rekonq too (probably any qtwebkit-based browser)

Comment 4 Rex Dieter 2010-07-18 20:27:33 UTC
Interesting, comment #2 says -38 is ok, though thomasj's bodhi comment found issue with that one as well,
https://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-38.b18.fc13

Comment 5 Rex Dieter 2010-07-18 21:00:49 UTC
backtrace from rekonq-0.5, trying to browse http://mlb.com/ ,

*** glibc detected *** rekonq: free(): invalid pointer: 0x0000000005bdb6e0 ***

Application: rekonq (rekonq), signal: Aborted
...

Thread 1 (Thread 0x7fd8d800a960 (LWP 13868)):
[KCrash Handler]
#5  0x00007fd8cfe8e9a5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007fd8cfe90185 in abort () at abort.c:92
#7  0x00007fd8cfecbd5b in __libc_message (do_abort=2, fmt=0x7fd8cff9f8f8 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:186
#8  0x00007fd8cfed1676 in malloc_printerr (action=3, str=0x7fd8cff9da45 "free(): invalid pointer", ptr=<value optimized out>) at malloc.c:6283
#9  0x00007fd8d09d84b5 in IA__g_strfreev (str_array=0x5bdb490) at gstrfuncs.c:2558
#10 0x00007fd89530219b in plugin_test_appletviewer (browserTable=<value optimized out>, pluginTable=<value optimized out>) at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1517
#11 NP_Initialize (browserTable=<value optimized out>, pluginTable=<value optimized out>) at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:2156
#12 0x00007fd8d7038dea in WebCore::PluginPackage::load() () from /usr/lib64/libQtWebKit.so.4
#13 0x00007fd8d7039c09 in WebCore::PluginPackage::fetchInfo() () from /usr/lib64/libQtWebKit.so.4
#14 0x00007fd8d6efdc64 in WebCore::PluginPackage::createPackage(WebCore::String const&, long const&) () from /usr/lib64/libQtWebKit.so.4
#15 0x00007fd8d6efa425 in WebCore::PluginDatabase::refresh() () from /usr/lib64/libQtWebKit.so.4
#16 0x00007fd8d6efc942 in WebCore::PluginDatabase::installedPlugins(bool) () from /usr/lib64/libQtWebKit.so.4
#17 0x00007fd8d7002293 in WebCore::PluginData::initPlugins() () from /usr/lib64/libQtWebKit.so.4
#18 0x00007fd8d6ea9720 in WebCore::PluginData::PluginData(WebCore::Page const*) () from /usr/lib64/libQtWebKit.so.4
#19 0x00007fd8d6e99178 in WebCore::Page::pluginData() const () from /usr/lib64/libQtWebKit.so.4
#20 0x00007fd8d6ea99b9 in WebCore::PluginArray::length() const () from /usr/lib64/libQtWebKit.so.4
#21 0x00007fd8d736ce31 in WebCore::jsPluginArrayLength(JSC::ExecState*, JSC::Identifier const&, JSC::PropertySlot const&) () from /usr/lib64/libQtWebKit.so.4
#22 0x00007fd8d6ae9202 in JSC::Interpreter::privateExecute(JSC::Interpreter::ExecutionFlag, JSC::RegisterFile*, JSC::ExecState*, JSC::JSValue*) () from /usr/lib64/libQtWebKit.so.4
#23 0x00007fd8d6af3a2f in JSC::Interpreter::execute(JSC::ProgramExecutable*, JSC::ExecState*, JSC::ScopeChainNode*, JSC::JSObject*, JSC::JSValue*) () from /usr/lib64/libQtWebKit.so.4
#24 0x00007fd8d6b23e24 in JSC::evaluate(JSC::ExecState*, JSC::ScopeChain&, JSC::SourceCode const&, JSC::JSValue) () from /usr/lib64/libQtWebKit.so.4
#25 0x00007fd8d6bdee85 in WebCore::evaluateInWorld(JSC::ExecState*, JSC::ScopeChain&, JSC::SourceCode const&, JSC::JSValue, WebCore::DOMWrapperWorld*) () from /usr/lib64/libQtWebKit.so.4
#26 0x00007fd8d6bec140 in WebCore::ScriptController::evaluateInWorld(WebCore::ScriptSourceCode const&, WebCore::DOMWrapperWorld*) () from /usr/lib64/libQtWebKit.so.4
#27 0x00007fd8d6bec362 in WebCore::ScriptController::evaluate(WebCore::ScriptSourceCode const&) () from /usr/lib64/libQtWebKit.so.4
#28 0x00007fd8d6bfc6fa in WebCore::ScriptController::executeScript(WebCore::ScriptSourceCode const&) () from /usr/lib64/libQtWebKit.so.4
#29 0x00007fd8d6dcbcc1 in WebCore::HTMLTokenizer::scriptExecution(WebCore::ScriptSourceCode const&, WebCore::HTMLTokenizer::State) () from /usr/lib64/libQtWebKit.so.4
#30 0x00007fd8d6dce235 in WebCore::HTMLTokenizer::scriptHandler(WebCore::HTMLTokenizer::State) () from /usr/lib64/libQtWebKit.so.4
#31 0x00007fd8d6dced42 in WebCore::HTMLTokenizer::parseNonHTMLText(WebCore::SegmentedString&, WebCore::HTMLTokenizer::State) () from /usr/lib64/libQtWebKit.so.4
#32 0x00007fd8d6dd2f24 in WebCore::HTMLTokenizer::parseTag(WebCore::SegmentedString&, WebCore::HTMLTokenizer::State) () from /usr/lib64/libQtWebKit.so.4
#33 0x00007fd8d6dd3362 in WebCore::HTMLTokenizer::write(WebCore::SegmentedString const&, bool) () from /usr/lib64/libQtWebKit.so.4
#34 0x00007fd8d6dcc429 in WebCore::HTMLTokenizer::notifyFinished(WebCore::CachedResource*) () from /usr/lib64/libQtWebKit.so.4
#35 0x00007fd8d6e08d2c in WebCore::CachedScript::checkNotify() () from /usr/lib64/libQtWebKit.so.4
#36 0x00007fd8d6e40dd3 in WebCore::Loader::Host::didFinishLoading(WebCore::SubresourceLoader*) () from /usr/lib64/libQtWebKit.so.4
#37 0x00007fd8d6e55c43 in WebCore::SubresourceLoader::didFinishLoading() () from /usr/lib64/libQtWebKit.so.4
#38 0x00007fd8d6fea20b in WebCore::QNetworkReplyHandler::finish() () from /usr/lib64/libQtWebKit.so.4
#39 0x00007fd8d6fea7d4 in WebCore::QNetworkReplyHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libQtWebKit.so.4
#40 0x00007fd8d363ff31 in QObject::event (this=0x58ce960, e=0x2a001c0) at kernel/qobject.cpp:1248
#41 0x00007fd8d3d0039c in QApplicationPrivate::notify_helper (this=0x260d330, receiver=0x58ce960, e=0x2a001c0) at kernel/qapplication.cpp:4306
#42 0x00007fd8d3d0665b in QApplication::notify (this=<value optimized out>, receiver=0x58ce960, e=0x2a001c0) at kernel/qapplication.cpp:4189
#43 0x00007fd8d5821016 in KApplication::notify (this=0x7fffbd090920, receiver=0x58ce960, event=0x2a001c0) at /usr/src/debug/kdelibs-4.4.5/kdeui/kernel/kapplication.cpp:302
#44 0x00007fd8d3630ddc in QCoreApplication::notifyInternal (this=0x7fffbd090920, receiver=0x58ce960, event=0x2a001c0) at kernel/qcoreapplication.cpp:726
#45 0x00007fd8d3632ed4 in sendEvent (receiver=0x0, event_type=0, data=0x25ad7e0) at kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x25ad7e0) at kernel/qcoreapplication.cpp:1367
#47 0x00007fd8d3656d23 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#49 0x00007fd8d09b7d02 in g_main_dispatch (context=0x25e5270) at gmain.c:1960
#50 IA__g_main_context_dispatch (context=0x25e5270) at gmain.c:2513
#51 0x00007fd8d09bbae8 in g_main_context_iterate (context=0x25e5270, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#52 0x00007fd8d09bbc9c in IA__g_main_context_iteration (context=0x25e5270, may_block=1) at gmain.c:2654
#53 0x00007fd8d3656863 in QEventDispatcherGlib::processEvents (this=0x25a8480, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#54 0x00007fd8d3d9f84e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007fd8d362f822 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007fd8d362faec in QEventLoop::exec (this=0x7fffbd090870, flags=...) at kernel/qeventloop.cpp:201
#57 0x00007fd8d36331bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#58 0x00007fd8d7c32132 in kdemain () from /usr/lib64/libkdeinit4_rekonq.so
#59 0x00007fd8cfe7ac5d in __libc_start_main (main=0x400940 <_start+240>, argc=2, ubp_av=0x7fffbd0910f8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffbd0910e8) at libc-start.c:226
#60 0x0000000000400879 in _start ()

Comment 6 Jaroslav Reznik 2010-07-26 15:36:42 UTC
Seems like it affects WebKit-Gtk too (Midori dies while initializing IcedTeaPlugin).

Comment 7 Garry Reisky 2010-07-27 04:19:27 UTC
After going back and forth using java-1.6.0-openjdk packages I was incorrect and as Rex said 38 has problems. The good version that works is ..  37.b17

Comment 8 d. johnson 2010-08-10 23:50:07 UTC
*** Bug 603358 has been marked as a duplicate of this bug. ***

Comment 9 Trevor Davenport 2010-08-11 16:31:50 UTC
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Tried to download 64bit firefox nightly(http://nightly.mozilla.org/).
Crashes on clicking the link.

Comment 10 Johan Olby 2010-08-11 18:48:05 UTC
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Fresh install of Epiphany (fedora 13 package)
2.Visit svanstroms.com (office supplies webshop)
3.*profit* (crash every time)

Comment 11 d. johnson 2010-08-13 11:22:45 UTC
*** Bug 598254 has been marked as a duplicate of this bug. ***

Comment 12 d. johnson 2010-08-13 15:50:26 UTC
*** Bug 605612 has been marked as a duplicate of this bug. ***

Comment 13 d. johnson 2010-08-13 16:16:42 UTC
*** Bug 606177 has been marked as a duplicate of this bug. ***

Comment 14 d. johnson 2010-08-13 16:18:12 UTC
*** Bug 606186 has been marked as a duplicate of this bug. ***

Comment 15 d. johnson 2010-08-13 16:19:56 UTC
*** Bug 606207 has been marked as a duplicate of this bug. ***

Comment 16 d. johnson 2010-08-13 18:07:20 UTC
*** Bug 601409 has been marked as a duplicate of this bug. ***

Comment 17 Evert Verhellen 2010-08-14 13:25:05 UTC
I encounter this crash with just Epiphany (epiphany-2.30.2-1.fc13.x86_64) and the OpenJDK plugin (java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.x86_64), no other plugins installed manually on this Fedora 13 system. I will upload the backtrace.

How to reproduce
-----
1. Install Epiphany (epiphany-2.30.2-1.fc13.x86_64) and the OpenJDK Web Browser
Plugin (java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.x86_64)
2. Start Epiphany.
3. Go to: http://www.java.com/en/download/installed.jsp
4. Click on "Verify Java Version".
5. Crash.

Comment 18 Evert Verhellen 2010-08-14 13:25:50 UTC
Created attachment 438793 [details]
Epiphany crash

Comment 19 d. johnson 2010-08-17 18:05:37 UTC
*** Bug 606985 has been marked as a duplicate of this bug. ***

Comment 20 d. johnson 2010-08-17 18:09:15 UTC
*** Bug 607013 has been marked as a duplicate of this bug. ***

Comment 21 d. johnson 2010-08-17 18:29:36 UTC
*** Bug 607206 has been marked as a duplicate of this bug. ***

Comment 22 d. johnson 2010-08-17 18:39:46 UTC
*** Bug 607363 has been marked as a duplicate of this bug. ***

Comment 23 d. johnson 2010-08-17 18:43:48 UTC
*** Bug 607391 has been marked as a duplicate of this bug. ***

Comment 24 Ed Cates 2010-08-19 15:11:27 UTC
I was having this problem, no matter what web page I tried to visit in konqueror.  I just upgraded to:

1.6.0.0-42-b18-fc13

for openjdk and openjdk-plugin, and Konqueror is usable again.  I encourage everyone else to give the update a try!

Comment 25 Joachim Frieben 2010-08-19 20:02:08 UTC
(In reply to comment #24)
Try any Java test page, e.g.

    http://www.java.com/en/download/help/testvm.xml .

Having upgraded to 1.6.0.0-42.b18.fc13, entering this URL results in an immediate crash.

Comment 26 d. johnson 2010-08-20 17:27:50 UTC
*** Bug 607992 has been marked as a duplicate of this bug. ***

Comment 27 d. johnson 2010-08-26 12:24:28 UTC
*** Bug 608026 has been marked as a duplicate of this bug. ***

Comment 28 d. johnson 2010-08-26 12:30:48 UTC
*** Bug 608037 has been marked as a duplicate of this bug. ***

Comment 29 jrussey 2010-10-02 14:21:36 UTC
Package: epiphany-2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.fresh install via yum installer
2.opened browser & enterred url
3.bang bang

Comment 30 Joachim Frieben 2010-10-23 13:13:59 UTC
Loading http://www.java.com/en/download/help/testvm.xml still crashes epiphany-2.30.2-1.fc13 and java-1.6.0-openjdk-plugin-1.6.0.0-43.1.8.2.fc13 as of Oct 13, 2010.

Comment 31 Joachim Frieben 2011-02-11 21:28:12 UTC
Created attachment 478317 [details]
Tail of .xsession-errors after verifying Java version at http://www.java.com

Loading http://www.java.com/en/download/help/testvm.xml still crashes
epiphany-2.30.2-1.fc13 and java-1.6.0-openjdk-plugin-1.6.0.0-50.1.8.6.fc13 as
of Feb 11, 2011.

Comment 32 Bug Zapper 2011-06-01 13:40:32 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 33 Bug Zapper 2011-06-29 13:24:09 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.