Bug 603386 - [Crestline] Login screen no longer cross-fades from final plymouth screen on Intel graphics
[Crestline] Login screen no longer cross-fades from final plymouth screen on ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
RejectedBlocker RejectedNTH
: Triaged
Depends On:
Blocks: F15Target
  Show dependency treegraph
 
Reported: 2010-06-12 15:44 EDT by James Ettle
Modified: 2018-04-11 03:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-18 14:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (68.43 KB, text/plain)
2010-06-15 06:33 EDT, James Ettle
no flags Details
/var/log/Xorg.0.log (58.89 KB, text/plain)
2010-06-15 06:33 EDT, James Ettle
no flags Details
dmesg output with drm.debug=0x04 (59.74 KB, text/plain)
2010-06-15 06:34 EDT, James Ettle
no flags Details
gdm :0.log (44.57 KB, text/plain)
2010-06-15 06:34 EDT, James Ettle
no flags Details
gdm :0-greeter.log (4.65 KB, text/plain)
2010-06-15 06:35 EDT, James Ettle
no flags Details
gdm :0-slave.log (98 bytes, text/plain)
2010-06-15 06:35 EDT, James Ettle
no flags Details

  None (edit)
Description James Ettle 2010-06-12 15:44:26 EDT
Description of problem:
OK, this is only a cosmetic thing, but under F12, the login screen used to cross-fade in nicely from whatever plymouth had left at the end of the boot process. Under F13, this is also the case on my ATI graphics machine, but with Intel graphics the screen turns black and then presents the login screen. (Intel X3100 graphics.)

[Filing under Intel driver since it seems to be working on the non-Intel hardware I can lay my hands on.]

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.11.0-4.fc13.x86_64
kernel-2.6.33.5-112.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
plymouth-0.8.2-3.fc13.x86_64
libdrm-2.4.20-1.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start the machine.
Comment 2 Matěj Cepl 2010-06-14 05:33:11 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* GDM log files (/var/log/gdm/*.log),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 James Ettle 2010-06-15 06:33:38 EDT
Created attachment 424100 [details]
/var/log/messages
Comment 4 James Ettle 2010-06-15 06:33:58 EDT
Created attachment 424101 [details]
/var/log/Xorg.0.log
Comment 5 James Ettle 2010-06-15 06:34:25 EDT
Created attachment 424102 [details]
dmesg output with drm.debug=0x04
Comment 6 James Ettle 2010-06-15 06:34:46 EDT
Created attachment 424103 [details]
gdm :0.log
Comment 7 James Ettle 2010-06-15 06:35:05 EDT
Created attachment 424104 [details]
gdm :0-greeter.log
Comment 8 James Ettle 2010-06-15 06:35:31 EDT
Created attachment 424105 [details]
gdm :0-slave.log
Comment 9 James Ettle 2010-06-15 06:36:01 EDT
No xorg.conf present.
Comment 10 Adam Williamson 2010-10-01 16:33:29 EDT
This was discussed at the 2010-10-01 blocker review meeting. This is a minor cosmetic issue which does not meet any of the release criteria; you still get a functioning desktop.
Comment 11 Andrew Duggan 2010-10-02 22:41:32 EDT
The release criteria should really be amended to include any known regression  automatically as a release blocker.

See http://fedoraproject.org/wiki/Features/IntelKMS (From F11) 

Under the test plan for that feature in F11 it says this:

"... that Fedora transitions into X from plymouth without flashes or blackouts,..."

This means with this bug Fedora 14 doesn't meet the criteria under which Fedora 11 was released even though the process then was not at all formal. 

Although personally I would rather this bug be closed as wontfix as that feature (KMS) from Fedora 11 broke Hibernate on Intel for two full releases, and now that is fixed, I can't say I have a lot of confidence that a fix for this bug won't break hibernate again for Intel.

It is rather ironic that in the name of a feature (KMS in F11) that Fedora broke important functionality for laptops with Intel video (hibernate), can't pass one of the test items important enough to make it into its original test plan and now it is dismissed with a hand-wave.  -- Any you all wonder why you lose users?
Comment 12 Mads Kiilerich 2011-03-04 14:15:01 EST
I see the same on F15 on 915GM/GMS/910GML

Shouldn't this be a F15 target?

kernel-PAE-2.6.38-0.rc6.git6.1.fc15.i686
plymouth-0.8.4-0.20110209.2.fc15.i686
gdm-2.91.91-1.fc15.i686
xorg-x11-drv-intel-2.14.0-2.fc15.i686

http://www.smolts.org/client/show/pub_20e91335-d5cd-4718-8b94-06be26502fc2
Comment 13 Mads Kiilerich 2011-03-07 10:23:41 EST
A couple of not intel-specific comments:

/etc/X11/prefdm still contains "plymouth quit". AFAIK that should be handled by gdm in F15.

No matter what, Xorg is started with
/usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-x/database -nolisten tcp
AFAIK it should be started with -nr - but that has perhaps been changed to -br?
Comment 14 Adam Williamson 2011-03-07 12:02:13 EST
"/etc/X11/prefdm still contains "plymouth quit". AFAIK that should be handled by
gdm in F15."

and if you're not using gdm?
Comment 15 Mads Kiilerich 2011-03-07 12:13:35 EST
gdm has been patched to support smooth fading. The content of prefdm indicates that kdm also has been patched. Users using other login managers do currently not get the same smooth experience. AFAIK all this hasn't changed since F12/13.

But I guess you are right, plymouth quit without --retain-splash should still be run for "other" login managers. I didn't want to pretend that I was an expert who knows all the details of the plan.
Comment 16 Adam Jackson 2011-04-18 14:22:33 EDT
Fixed in -intel 2.14.0-5.fc15.

Note You need to log in before you can comment on or make changes to this bug.