Bug 603468 - pcmanfm update to 0.9.7-1.fc13 breaks managing desktop under LXDE
pcmanfm update to 0.9.7-1.fc13 breaks managing desktop under LXDE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxde-common (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 604028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 07:07 EDT by Corinna Vinschen
Modified: 2010-06-16 13:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: lxde-common-0.5.4-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 13:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corinna Vinschen 2010-06-13 07:07:16 EDT
Description of problem:

After the update from 0.9.5-1.fc13 to 0.9.7-1.fc13, the LXDE desktop
did not show any Desktop icon, nor the configured background.
Instead, the background was invariably set to the goddard.jpg
picture.

Version-Release number of selected component (if applicable):

0.9.7-1

How reproducible:

Just install the latest 0.9.7-1 package and start a LXDE session.

Reason:

The 0.9.7-1.fc13 package has been built incorrectly.  The former
0.9.5-1.fc13 package had a binary /usr/bin/pcmanfm2, and a symlink
/usr/bin/pcmanfm pointing to /usr/bin/pcmanfm2.  The new 0.9.7-1.fc13
package has only a binary called /usr/bin/pcmanfm and no file called
/usr/bin/pcmanfm2.

Unfortunately the LXDE autostart file /etc/xdg/lxsession/LXDE/autostart
contains this line to start pcmanfm:

  @pcmanfm2 --desktop --profile lxde

Since there's no such file pcmanfm2 anymore, starting the file manager
to manage the desktop fails.

Solution:

Either create a new package for pcmanfm which re-introduces the
pcmanfm2 file (either as symlink to pcmanfm or vice versa as in
the 0.9.5-1.fc13 package), or create a new lxde-common package
which refers to pcmanfm instead of to pcmanfm2.
Comment 1 Mamoru TASAKA 2010-06-13 07:30:10 EDT
This rename is upstream change, so fixing lxde-common (and ping
upstream) is better.
Comment 3 Mamoru TASAKA 2010-06-13 12:54:42 EDT
Christoph, for now I applied a patch for lxde-common.
Please fix if needed.

Corinna, would you check if the following works?
http://kojipkgs.fedoraproject.org/packages/lxde-common/0.5.4/2.fc13/
Comment 4 Christoph Wickert 2010-06-13 13:06:18 EDT
Mamoru, I welcome your quick response, but I don't think it is productive to touch my package without previous notice. I have been working on this but I wasn't able to commit my changes due to the lack of time during Linuxtag. Now I need to merge everything which causes additional work and delay. :(
Comment 5 Corinna Vinschen 2010-06-13 14:25:31 EDT
(In reply to comment #3)
> Christoph, for now I applied a patch for lxde-common.
> Please fix if needed.
> 
> Corinna, would you check if the following works?
> http://kojipkgs.fedoraproject.org/packages/lxde-common/0.5.4/2.fc13/    

Yes, that works.  It's the same patch I used locally already.

Thanks,
Corinna
Comment 6 Mamoru TASAKA 2010-06-15 05:03:26 EDT
*** Bug 604028 has been marked as a duplicate of this bug. ***
Comment 7 Mamoru TASAKA 2010-06-15 12:11:59 EDT
Well, as actually at least 2 people complained about this issue,
I would like to submit a update for lxde-common instread of
Christoph (because he seems busy with Linuxtag).

Christoph, please modify lxde-common if you find something wrong.
Comment 8 Fedora Update System 2010-06-15 12:15:14 EDT
lxde-common-0.5.4-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lxde-common-0.5.4-2.fc13
Comment 9 Fedora Update System 2010-06-16 13:47:13 EDT
lxde-common-0.5.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.