Bug 604028 - pcmanfm package doesn't contain /usr/bin/pcmanfm2
Summary: pcmanfm package doesn't contain /usr/bin/pcmanfm2
Status: CLOSED DUPLICATE of bug 603468
Alias: None
Product: Fedora
Classification: Fedora
Component: pcmanfm   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 08:28 UTC by Tomas Lestach
Modified: 2010-06-15 09:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 09:03:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Lestach 2010-06-15 08:28:56 UTC
Description of problem:
/etc/xdg/lxsession/LXDE/autostart constains followig line:
@pcmanfm2 --desktop --profile lxde
But pcmanfm2 isn't part of the pcmanfm-0.9.7-1.fc13.x86_64 package, like it was in previous versions (pcmanfm-0.9.5-1.fc13.x86_64.rpm). Looks like a regression.

Version-Release number of selected component (if applicable):
Fedora13 LXDE
lxde-common-0.5.4-1.fc13.noarch
pcmanfm-0.9.7-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
# grep pcmanfm2 /etc/xdg/lxsession/LXDE/autostart
@pcmanfm2 --desktop --profile lxde

# which pcmanfm2
/usr/bin/which: no pcmanfm2 in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)

# rpm -qf /etc/xdg/lxsession/LXDE/autostart
lxde-common-0.5.4-1.fc13.noarch
# rpm -ql pcmanfm | grep pcmanfm2
#

1. Uncheck "Show menus provided by windows managers when desktop is clicked" in Desktop Preferences.
2. Log out and and log in as same user.
3. Right click on desktop

Actual results:
Due to the missing pcmanfm2 this feature doesn't work. LXDE menu is displayed.

Expected results:
Possibility to disable LXDE menu.

Additional info:
Not sure, if this is a problem of pcmanfm package or of lxde-common.

Workaround:
Replace pcmanfm2 with pcmanfm /etc/xdg/lxsession/LXDE/autostart

Comment 1 Mamoru TASAKA 2010-06-15 09:03:26 UTC

*** This bug has been marked as a duplicate of bug 603468 ***


Note You need to log in before you can comment on or make changes to this bug.