Bug 603476 - Octave crashes when QtOctave starts
Summary: Octave crashes when QtOctave starts
Status: CLOSED DUPLICATE of bug 562276
Alias: None
Product: Fedora
Classification: Fedora
Component: octave-forge   
(Show other bugs)
Version: 13
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 603469 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-13 12:05 UTC by Digvijay Patankar
Modified: 2010-06-16 21:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 21:08:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (12.36 KB, application/octet-stream)
2010-06-13 12:07 UTC, Digvijay Patankar
no flags Details

Description Digvijay Patankar 2010-06-13 12:05:19 UTC
Description of problem:
Every time I start QtOctave, Octave crashes. It displays a message saying Octave has crashed and restarting.
Once I click OK, it does not restart but everything goes normally hereafter.

Version-Release number of selected component (if applicable):
qtoctave-0.9.1-2.fc13.i686
octave-3.2.4-2.fc13.i686

How reproducible:
Start QtOctave


Steps to Reproduce:
1. Start QtOctave with Application > Education > QtOctave
2.
3.
  
Actual results:
Octave crashes and then continues normally

Expected results:
Octave must not crash.

Additional info:
Backtrace attached

Comment 1 Digvijay Patankar 2010-06-13 12:07:34 UTC
Created attachment 423622 [details]
Backtrace

Comment 2 Digvijay Patankar 2010-06-13 12:10:04 UTC
*** Bug 603469 has been marked as a duplicate of this bug. ***

Comment 3 nucleo 2010-06-13 12:28:10 UTC
Is octave crashes when running from console (without qtoctave)?
Is it crashes if octave-forge not installed?

Comment 4 Digvijay Patankar 2010-06-13 12:37:03 UTC
Is octave crashes when running from console (without qtoctave)?
- No, it doesn't. It runs fine without any crash.

Is it crashes if octave-forge not installed? 
- No, it doesn't.

I erased octave-forge and found that QtOctave is *not* crashing.
I again installed octave-forge and now its *crashing* again.

Comment 5 nucleo 2010-06-13 13:19:34 UTC
Can you try to run qtoctave with clean ~/.qtoctave config dir?

Comment 6 nucleo 2010-06-13 13:43:51 UTC
Reassigning this bug to octave-forge.

Comment 7 Digvijay Patankar 2010-06-13 13:48:21 UTC
Yes, when I try to run QtOctave with clean ~/.qtoctave dir, there is *no crash* anymore.

Comment 8 Alex Lancaster 2010-06-13 15:57:23 UTC
(In reply to comment #7)
> Yes, when I try to run QtOctave with clean ~/.qtoctave dir, there is *no crash*
> anymore.    

No crash even with octave-forge installed?  If so, then this bug can be closed.

Comment 9 nucleo 2010-06-13 16:04:41 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Yes, when I try to run QtOctave with clean ~/.qtoctave dir, there is *no crash*
> > anymore.    
> 
> No crash even with octave-forge installed?  If so, then this bug can be closed.    

Crash happens at second qtoctave start after cleaning ~/.qtoctave dir (I guess  may be some additional parameters passed to octave at second start).

Comment 10 Digvijay Patankar 2010-06-13 16:28:50 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Yes, when I try to run QtOctave with clean ~/.qtoctave dir, there is *no crash*
> > anymore.    
> 
> No crash even with octave-forge installed?  If so, then this bug can be closed.    

let me clear the scenario :

1. I clean ~/.qtoctave dir
2. Run QtOctave
3. No crash
4. But this run created some files in dir

Now I keep the ~/.qtoctave dir as it is (*not* cleaning the content)
i.e. this is the second run.
Here QtOctave *crashes*.

So as pointed out by nucleo, something from ~/.qtoctave dir must be interfering causing Octave to crash. 

I found that cleaning the whole directory is not required. I can simply run 'clear all' from QtOctave terminal and then next time I run QtOctave, it wont crash. But again if I run QtOctave for next time (without using 'clear all' before closing), it will crash.

So I think it has something to do with .variables file.

Comment 11 Alex Lancaster 2010-06-16 18:55:07 UTC
This might be the same as, or related to, bug #562276.  Can you try to leave octave-forge installed, but disable the "ann" package.  The way I did this was move all the ann-1.0.2 subdirectories:

rpm -ql octave-forge|grep ann-
/usr/libexec/octave/packages/ann-1.0.2
/usr/libexec/octave/packages/ann-1.0.2/x86_64-redhat-linux-gnu-api-v37
/usr/libexec/octave/packages/ann-1.0.2/x86_64-redhat-linux-gnu-api-v37/PKG_ADD
/usr/libexec/octave/packages/ann-1.0.2/x86_64-redhat-linux-gnu-api-v37/ann.oct
/usr/share/octave/packages/ann-1.0.2
/usr/share/octave/packages/ann-1.0.2/packinfo
/usr/share/octave/packages/ann-1.0.2/packinfo/.autoload
/usr/share/octave/packages/ann-1.0.2/packinfo/COPYING
/usr/share/octave/packages/ann-1.0.2/packinfo/ChangeLog
/usr/share/octave/packages/ann-1.0.2/packinfo/DESCRIPTION
/usr/share/octave/packages/ann-1.0.2/packinfo/INDEX
/usr/share/octave/packages/ann-1.0.2/packinfo/dist_admin
/usr/share/octave/packages/ann-1.0.2/packinfo/on_uninstall.m

into disabled subdirectories, i.e.:

$ cd /usr/libexec/octave/packages/
$ sudo mkdir disabled
$ mv -i ann-1.0.2 disabled/

etc.  then I modified (after taking a backup) /usr/share/octave/octave_packages to remove references to the ann package.  This seemed to disable the ann package and I could not duplicate the bug using the method described in bug #562276 comment #10.

Make sure you do all this from plain octave terminal initially.  Then try to duplicate within qtoctave.

Comment 12 Digvijay Patankar 2010-06-16 19:34:31 UTC
Yes, now the qtoctave is *not* crashing anymore.

Keeping octave-forge installed, I disabled the ann package. 
And now it works without any crash or not even one 'mark_as_xxxxx deprecated' warning

Comment 13 Alex Lancaster 2010-06-16 21:08:11 UTC

*** This bug has been marked as a duplicate of bug 562276 ***


Note You need to log in before you can comment on or make changes to this bug.