Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 603615 - Openais client blocked indefinitely on semaphore when the server goes down
Openais client blocked indefinitely on semaphore when the server goes down
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
: 604795 (view as bug list)
Depends On: 579081
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 03:36 EDT by RHEL Product and Program Management
Modified: 2016-04-26 11:41 EDT (History)
11 users (show)

See Also:
Fixed In Version: openais-0.80.6-16.el5_5.4
Doc Type: Bug Fix
Doc Text:
When an Openais client process sent an event to the server (aisexec), the server stopped working. When the client process tried to send the event using the saEvtEventPublish() function, it hanged indefinitely on a semaphore (semop()) operation. Even when the server was restarted, the blocked client process was still blocked. With this update, the client process no longer hangs indefinitely and is unblocked after a set period of time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 06:45:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0629 normal SHIPPED_LIVE openais bug fix update 2010-08-13 06:45:32 EDT

  None (edit)
Description RHEL Product and Program Management 2010-06-14 03:36:42 EDT
This bug has been copied from bug #579081 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 3 Steven Dake 2010-06-22 16:41:43 EDT
*** Bug 604795 has been marked as a duplicate of this bug. ***
Comment 7 Martin Prpič 2010-08-05 05:08:36 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When an Openais client process sent an event to the server (aisexec), the server stopped working. When the client process tried to send the event using the saEvtEventPublish() function, it hanged indefinitely on a semaphore (semop()) operation. Even when the server was restarted, the blocked client process was still blocked. With this update, the client process no longer hangs indefinitely and is unblocked after a set period of time.
Comment 11 errata-xmlrpc 2010-08-13 06:45:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0629.html

Note You need to log in before you can comment on or make changes to this bug.