Bug 604795 - Openais client blocked indefinitely on semaphore when the server goes down
Summary: Openais client blocked indefinitely on semaphore when the server goes down
Status: CLOSED DUPLICATE of bug 603615
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On: 579081
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 18:20 UTC by Benjamin Kahn
Modified: 2016-04-26 14:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When an Openais client process sent an event to the server (aisexec), the server stopped working. When the client process tried to send the event using the saEvtEventPublish() function, it hung indefinitely on a semaphore (semop()) operation. Even when the server was restarted, the blocked client process was still blocked. With this update, the client process no longer hangs indefinitely and is unblocked after a set period of time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 20:41:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benjamin Kahn 2010-06-16 18:20:40 UTC
This bug has been copied from bug #579081 and has been proposed
to be backported to 5.5 z-stream (EUS).

Comment 3 Steven Dake 2010-06-22 20:41:43 UTC

*** This bug has been marked as a duplicate of bug 603615 ***

Comment 4 Douglas Silas 2011-01-11 23:19:02 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When an Openais client process sent an event to the server (aisexec), the server stopped working. When the client process tried to send the event using the saEvtEventPublish() function, it hung indefinitely on a semaphore (semop()) operation. Even when the server was restarted, the blocked client process was still blocked. With this update, the client process no longer hangs indefinitely and is unblocked after a set period of time.


Note You need to log in before you can comment on or make changes to this bug.