This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 6038 - You don't have any Linux partitions. You can't upgrade this system! -reported on SCSI system with linux partitions
You don't have any Linux partitions. You can't upgrade this system! -reported...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-18 04:16 EDT by peter.lofgren
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 15:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description peter.lofgren 1999-10-18 04:16:12 EDT
My system is a PII400, with an Adaptec 2940U2W/IBM scsi
disk/Seagate tapedrive, and a ide-cdrom attached as primary
master. When trying to uopgrade, the system reports that I
don't have any linux partitions (which I do). Have tried to
disconnect the tape drive from the scsi-chain in order to
make sure ther where no termination errors, with no luck.
Neither graphics, text or expert-mode work. Also tried the
option aic7xxx=no_probe and still no reported linux
partitions.

Below some system information and reported messages

fstab
/dev/sda5	/	ext2	defaults	1 1
/dev/sda6	/abab	ext2	defaults	1 2
/dev/sda1	/boot	ext2	defaults	1 2
/dev/sda8	/home	ext2	defaults	1 2
/dev/sda7	/usr	ext2	defaults	1 2
/dev/sda9	/var	ext2	defaults	1 2
/dev/sda2	swap	ext2	defaults	0 0
/dev/fd0	/mnt/floppy	ext2	noauto	0 0
/dev/cdrom	/mnt/cdrom	is9660	noauto, ro	0 0
none		/proc	proc	defaults	0 0
none		/dev/pts	devpts	gid=5,mode620	0 0

tty3
* probing buses
* finished bus probing
* found suggestion of aic7xxx
* found aic7xxx device
* found devices justprobe is 0
* going to insmod aic7xxx.o (path is NULL)
* trying to mount device hda
* probing buses
* finished bus probing
* found suggestion of 3c59x
* found 3c59x device
* found suggestion of aic7xxx
* found aic7xxx device
* found suggestion of Card:ATI Mach64 3D Rage IIC
* found devices justProbe is 0
* going to insmod 3c59x.o (path is NULL)
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod raid5.o (path is NULL)
*** After second upgrade attempt
* Error in swapon of sda2: Device or resource busy

tty4
scsi0: Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI)
5.1.20/3.2.4
       <Adaptec AHA-294x Ultra2 SCSI host adapter>
scsi  : 1 host.
(scsi0:0:0:0) Synchronus at 80,0 Mbyte/sec, offset 15.
  Vendor: IBM	Model: DDRS-39130D	REV: DC1B
  Type:	Direct-Access			ANSI SCSI revision:
02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:4:0) Synchronous at 10.0 Mbyte/sec, offset 15
  Vendor: Seagate Model: STT8000N	REV: 3.22
  Type: Sequential-Access		ANSI SCSI revision:
02
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17850000
[8715 MB] [8.7 GB]
 sda: sda1 sda2 sda3 < sda5 sda6 sda7 sda8 sda9 >
VFS: Disk change detected on device ide0(3,0)
ISO 9660 Extensions: Microsoft Joliet Level 1
ISO 9660 Extensions: RRIP_1991A
3c59x.c:v0.99H 11/17/98 Donald Becker (etc, left out)
eth0: 3Com 3c905B Cyclone 100BaseTx at 0xe800,
00:50:04:69:d3:20, IRQ 5
  8K byte-wide RAM 5:3 Rx:Tx split,
autoselect/Autonegotiate interface.
  MII transceivier found at address 24, status 782d.
  Enabling bus-mastert transmits and whole-fram recevies.
raid0 personality registered
raid1 personality registered
raid5 personality registered
*** After first upgrade attempt
Adding Swap: 136544k swap-space (prioroty -1)
Comment 1 Jay Turner 1999-10-18 12:42:59 EDT
Don't know whether this is a mistype of what, but one problem is that
the swap partition that you have listed below is of type ext2 and
should be of type swap.  Now, from the other messages that you
attached, I cannot tell what the problem is.  The system is seeing all
of your partitions and therefore should be able to find the existing
installation and should perform the upgrade on those partitions.  Send
me more error output and let me know where you are seeing the problem.
Comment 2 peter.lofgren 1999-10-19 16:30:59 EDT
The ext2 for swap was a typo, it is 'swap' in my fstab.
The error message 'You don't have any Linux partitions. You can't
upgrade this system!' is seen right after I choose the upgrade option.
Have tried to find any additional error messages for you, but this is
all thats printed on the tty's. Is there any additional place to look?

This is the only additional output (tty4) that I've seen
hda: irq timeout: status=0xd0 { Busy }
hda: ATAPI reset complete

Also tried to set sda1 (/boot) as active, none of the partions where
set as active. Didn't help. Also, the 'DOS-large disk option' in the
adaptec bios is disabled (have tried both settings)

Since the system is able to swapon my sda2 swap space, I guess the
installer is seing my SCSI disk. It is also correctly reported in
disk druid choosing custom install (without going any further).

My theory:
All the original partitioning was done using Partion Magic 4.01.
Using fdisk, and the p option list the partition id as 83, and 82 for
swap. But the extended partition is type f - win95, where the root
partition is enclosed. You think it might help if changed to 85 Linux
extended, or 5 Extended. How do i go about, and change it, and what
security measures should I take?


Some additional info on my system
disk gemoetry (C/H/S) (1111/255/63) reported by disk druid
Award Modular Bios 4.51PG
1st Mainboard, intel 440BX
Adaptec AHA2940U2W v2.20.0 (upgraded from v2.01, tried upgrading
before and after)
Comment 3 Chris Siebenmann 1999-10-21 04:15:59 EDT
As you've guessed, the problem is that the extended partition type
is set to '0f' (Windows Extended) instead of '05' (plain Extended).
Anaconda (the installer in 6.1) specifically only looks for extended
partitions inside a type '05' primary partition. One person here
(with this problem) experienced no problems in simply changing the
partition type from 0f to 05.

 In general, I suspect that Anaconda's disk partition parsing is
fragile. Perhaps in future releases, RedHat should just copy the
code from fdisk or the like (even if it is larger).

 Curious people can look in misc/src/anaconda/balkan/dos.c on the
install image for the gory details.
Comment 4 Jay Turner 1999-10-21 15:29:59 EDT
*** This bug has been marked as a duplicate of 5511 ***

Note You need to log in before you can comment on or make changes to this bug.