Bug 603913 - cluster status message passing among nodes is broken
Summary: cluster status message passing among nodes is broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: clustermon   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 616377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-14 20:33 UTC by Chris Feist
Modified: 2016-04-26 14:53 UTC (History)
5 users (show)

Fixed In Version: clustermon-0.16.2-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 22:06:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix node communication through modclusterd (4.80 KB, application/octet-stream)
2010-08-04 03:37 UTC, Ryan McCabe
no flags Details

Description Chris Feist 2010-06-14 20:33:21 UTC
Description of problem:
Luci only talks to ricci on one node of the cluster, if that node's cluster infrastructure is stopped (service cman stop), luci will continue using that node and erroneously report that there is no cluster formed.

Version-Release number of selected component (if applicable):
luci-0.22.2-2.el6

How reproducible:
Everytime

Steps to Reproduce:
1. Create/Add a 2 node cluster 
2. Stop ricci on first node
3. Hit refresh in the luci interface 3 times
4. start ricci on the first node
5. Run 'service cman stop' on the second node
6. Refresh the luci interface 3 times, both nodes will appear to be not members of the cluster.
7. Login to the 1st node and run 'cman_tool status', you will see that the cluster is still in fact running and that the 1st node is a member of the cluster.

  
Actual results:
Cluster appears to be down from luci interface

Expected results:
Luci should show that the cluster is working but the second node is not part of the cluster

Comment 1 RHEL Product and Program Management 2010-06-14 20:43:00 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 7 Ryan McCabe 2010-07-26 14:42:46 UTC
*** Bug 616377 has been marked as a duplicate of this bug. ***

Comment 11 Ryan McCabe 2010-08-04 03:37:08 UTC
Created attachment 436426 [details]
fix node communication through modclusterd

Comment 19 releng-rhel@redhat.com 2010-11-10 22:06:52 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.