Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604024 - display is having redrawing issues when rotated
display is having redrawing issues when rotated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: 605348
  Show dependency treegraph
 
Reported: 2010-06-15 04:09 EDT by Lubos Kocman
Modified: 2010-11-10 16:56 EST (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.11.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:56:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xrandr output (1.19 KB, text/plain)
2010-06-15 04:13 EDT, Lubos Kocman
no flags Details
xorg.log (380.91 KB, text/plain)
2010-06-15 04:13 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-06-15 04:09:16 EDT
Description of problem:

Problem occurs while secondary display is rotated to:

left
right
upside down


Version-Release number of selected component (if applicable):

kernel-2.6.32-33.el6.x86_64
xorg-x11-drv-intel-2.11.0-5.el6.x86_64
mesa-libGLU-devel-7.7-2.el6.x86_64
mesa-libGL-7.7-2.el6.x86_64
mesa-dri-drivers-7.7-2.el6.x86_64
mesa-libGLU-7.7-2.el6.x86_64
mesa-libGL-devel-7.7-2.el6.x86_64
xorg-x11-server-Xorg-1.7.7-8.el6.x86_64

How reproducible:

reproducible always


Steps to Reproduce:
1. Connect extended display
2. Use Xrandr or System->Preferences->Display to rotate extended display (e.g. to left)
3. Open gnome-terminal and hit few times enter (prompt will have redrawing problems, the same happens with pop-up menus in gnome)
  
Actual results:

Redrawing issues

Expected results:

No redrawing issues

Additional info:

The same issue occurs on Fedora 13 on the same hardware.

Thinkpad T400/RHEL6 x86_64

[lkocman@dhcp-29-7 src]$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 1 Lubos Kocman 2010-06-15 04:13:18 EDT
Created attachment 424069 [details]
xrandr output
Comment 2 Lubos Kocman 2010-06-15 04:13:50 EDT
Created attachment 424070 [details]
xorg.log
Comment 3 Lubos Kocman 2010-06-15 04:14:56 EDT
Problem does not occur while Compiz effects (Preferences->Desktop Effects-> Compiz) are turned on.
Comment 5 Lubos Kocman 2010-06-15 04:31:41 EDT
Issue occurs also on rotated primary display.
Comment 6 RHEL Product and Program Management 2010-06-15 04:33:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Matěj Cepl 2010-06-15 07:15:29 EDT
Yes, can reproduce here, but it seems like it is rather minor glitch and it tends to correct itself after a brief period of time. Agree?
Comment 8 Marian Csontos 2010-06-15 07:50:44 EDT
Minor glitch? Try working with this glitch-feature enabled.
It impacts pretty much whole GUI, Firefox, everything...
Comment 9 Lubos Kocman 2010-06-15 08:04:23 EDT
Working with this "minor glitch" is really painful redrawing is slow.

And it's not really pleasant/safe to see corrupted name of the file that you're going to remove .... like:

rm fi       .t t

Especially curses based applications suffer from this all the time while using them.

I see this as a blocker, lots of people here are using flipped widescreen to the left. And this is really a problem.
Comment 11 Adam Jackson 2010-06-16 11:47:54 EDT
I am unable to reproduce this with:

kernel-2.6.32-33.el6.x86_64
xorg-x11-drv-intel-2.11.0-5.el6.x86_64
xorg-x11-server-Xorg-1.7.7-11.el6.x86_64

at least not on 5-series.  I'll dig up a 4-series to confirm, but if you could retest with newer versions that'd be great
Comment 12 Lubos Kocman 2010-06-17 02:37:48 EDT
Hello,

I'm always trying to be as updated as possible. And as I said this issue is also on Fedora which has most probably much newer releases ...
Comment 13 Adam Jackson 2010-06-23 12:08:18 EDT
That's not an answer.  Can you reproduce this with current RHEL6 packages, and if so, which ones?
Comment 14 Dave Airlie 2010-06-23 21:35:02 EDT
okay reproduced this or something like it on my 965gm with rotated screen, I'm not seeing it too the same extent, but I am seeing a lag on each keystroke in the terminal like a flush is missing or something.
Comment 15 Lubos Kocman 2010-06-24 09:34:20 EDT
Hello,

I'm able to reproduce it with RHEL6 on following packages:

xorg-x11-server-Xorg-1.7.7-12.el6.x86_64
xorg-x11-server-common-1.7.7-12.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
libXrandr-1.3.0-4.el6.x86_64
mesa-libGL-7.7-2.el6.x86_64
mesa-libGLU-7.7-2.el6.x86_64
mesa-dri-drivers-7.7-2.el6.x86_64
xorg-x11-drv-intel-2.11.0-5.el6.x86_64


Dave could you please test it on  popup menus? (e.g. right click on desktop placed on rotated display?) Highlighting of the current item is messed up as well as redrawing in the terminal.
Comment 16 Dave Airlie 2010-06-24 21:13:19 EDT
I've built xorg-x11-drv-intel-2.11.0-6.el6 in brew.

can you test and feedback here?
Comment 17 Lubos Kocman 2010-06-25 09:06:53 EDT
Hello Dave,

the issue is now fixed. Tested on xorg-x11-drv-intel-2.11.0-6.el6.x86_64.

Thank you
Comment 18 Lubos Kocman 2010-06-29 10:55:46 EDT
Verified on:

xorg-x11-drv-intel-2.11.0-6.el6. Issue no longer occurs in this driver.
Comment 19 releng-rhel@redhat.com 2010-11-10 16:56:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.