Bug 605348 - Screen repaint problems
Screen repaint problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On: 604024
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 13:13 EDT by Petr Machata
Modified: 2018-04-11 06:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.11.0-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 14:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (83.60 KB, text/plain)
2010-06-17 13:15 EDT, Petr Machata
no flags Details
Smolt profile (7.21 KB, text/plain)
2010-06-17 13:15 EDT, Petr Machata
no flags Details
compressed dmesg.log (28.95 KB, application/x-bzip2)
2010-06-17 13:48 EDT, Petr Machata
no flags Details
xorg.conf (783 bytes, text/plain)
2010-06-17 14:11 EDT, Petr Machata
no flags Details

  None (edit)
Description Petr Machata 2010-06-17 13:13:17 EDT
Description of problem:
I don't actually know what component to file this under, so I picked the Intel driver.  My problem is that various apps have problems with the contents of their windows being updated in time.

The most prominent example is emacs, where the character under cursor (or sometimes even next to it) disappears and takes a couple seconds before it appears again.  When the cursor is blinking, the effect is that the character under the cursor blinks quite randomly, appearing and disappearing, as the cursor itself blinks regularly and properly.  Turning the cursor blinking off makes the problem somewhat tolerable.  Or when I point to an URL (in emacs IRC client), the lower part of it disappears and again takes some time to reappear.  Or there would be pixel-wide horizontal lines that failed to update.

Another application that I had doing this was gtim, a trivial GTK clock for system tray.  Another example is WindowMaker crash dialogue or, more practically, the WPrefs application.  Yet another example is OpenOffice, where in font selection box the font that I point to disappears for a split second before it appears again.

Most applications work fine though, like firefox, thunderbird, the terminal, even emacs in terminal -- there are no problems with those.

I'm running this all under xmonad (a tiling window manager).  What's interesting is that under gnome (I suppose that's metacity), emacs renders fine.  I didn't try OOo or WPrefs, it only occurred to me later to even try it out.  I tried to make a screenshot or a screen capture of the bug, but firstly, with these measures on, the bug is less prominent--the repaints are more rapid.  And secondly, the bug itself never gets to the video, perhaps the pending redraws get committed just before the screenshot takes place, or something of the sort.

I don't use xorg.conf.

How reproducible:
Always.

Steps to Reproduce:
1. Run WPrefs (it's installed as part of WindowMaker package)
2. Switch to 5th tab
3. In "Size Display" box click the menu and move the mouse to select various options.
4. Observe the effects that I described above.
Comment 1 Petr Machata 2010-06-17 13:15:07 EDT
Created attachment 424886 [details]
Xorg.0.log

There are more Xorg.*.log files, but this one is the only recent (others are from F 12).  Are you still interested in those other logs?
Comment 2 Petr Machata 2010-06-17 13:15:47 EDT
Created attachment 424888 [details]
Smolt profile
Comment 3 Petr Machata 2010-06-17 13:48:00 EDT
Created attachment 424892 [details]
compressed dmesg.log
Comment 4 Petr Machata 2010-06-17 13:56:00 EDT
... oh, and all this started occurring after I updated to F 13.
Comment 5 Petr Machata 2010-06-17 14:11:44 EDT
Created attachment 424896 [details]
xorg.conf

And I just noticed that I actually do have xorg.conf.  Sorry, I thought I stopped using it ages ago.  I'm attaching it.  I tried to move it away (hence the *-1 name), and the problem is still present after restarting X.
Comment 6 Petr Machata 2010-06-17 14:15:38 EDT
The computer that I have this problem on is Lenovo X61.
I unplugged the external monitor and restarted X, but the problem remains.
Comment 7 Petr Machata 2010-06-17 14:28:13 EDT
Versions of relevant packages:
xorg-x11-drv-intel-2.11.0-4.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
libdrm-2.4.20-1.fc13.x86_64
Comment 8 Petr Machata 2010-06-17 14:45:17 EDT
FWIW, I tried to adjust my .xsession file to only contain "exec metacity", and the problem was still there.  So whatever bug-fixing powers are present in gnome, they are not present is metacity alone.
Comment 9 Matěj Cepl 2010-06-17 17:42:25 EDT
(In reply to comment #5)
> Created an attachment (id=424896) [details]
> xorg.conf
> 
> And I just noticed that I actually do have xorg.conf.  Sorry, I thought I
> stopped using it ages ago.  I'm attaching it.  I tried to move it away (hence
> the *-1 name), and the problem is still present after restarting X.    

It seems to me that it is completely useless ... if you use Gnome or KDE, you can set up the same keyboard layout options with their graphical tools, and the rest seems to be default anyway.

Anyway, reporter, do you think this look similar to bug 604024?
Comment 10 Petr Machata 2010-06-17 19:11:48 EDT
(In reply to comment #9)
> Anyway, reporter, do you think this look similar to bug 604024?    

Yes, I'd call it similar.  Interestingly enough this setting fixes my emacs, but WPrefs menus still act funny.  When the screen is rotated, I can also see the problems in firefox, which makes no problems normally.
Comment 12 Fedora Update System 2010-06-24 21:30:31 EDT
xorg-x11-drv-intel-2.11.0-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.11.0-5.fc13
Comment 13 Fedora Update System 2010-06-25 14:22:42 EDT
xorg-x11-drv-intel-2.11.0-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-intel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.11.0-5.fc13
Comment 14 Fedora Update System 2010-07-01 14:39:25 EDT
xorg-x11-drv-intel-2.11.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.