Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604443 - TUNSETIFF denied: denied { relabelfrom }
TUNSETIFF denied: denied { relabelfrom }
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 609000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 17:53 EDT by David Woodhouse
Modified: 2010-12-03 08:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 08:50:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2010-06-15 17:53:26 EDT
Jun 15 22:50:42 i7 openconnect[3187]: Connected to HTTPS on 192.55.37.76
Jun 15 22:50:42 i7 openconnect[3187]: Got CONNECT response: HTTP/1.1 200 OK
Jun 15 22:50:42 i7 openconnect[3187]: CSTP connected. DPD 30, Keepalive 15
Jun 15 22:50:42 i7 openconnect[3187]: TUNSETIFF failed: Permission denied

Source Context                system_u:system_r:vpnc_t:s0
Target Context                system_u:system_r:vpnc_t:s0
Target Objects                None [ tun_socket ]
Source                        openconnect
Source Path                   /usr/bin/openconnect
Port                          <Unknown>
Host                          i7.infradead.org
Source RPM Packages           openconnect-2.22-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     i7.infradead.org
Platform                      Linux i7.infradead.org 2.6.33.5-112.fc13.x86_64 #1
                              SMP Thu May 27 02:28:31 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue Jun 15 22:50:42 2010
Last Seen                     Tue Jun 15 22:50:42 2010
Local ID                      44ff9b90-13fd-4914-a5e6-700468f453df
Line Numbers                  

Raw Audit Messages            

node=i7.infradead.org type=AVC msg=audit(1276638642.484:113): avc:  denied  { relabelfrom } for  pid=3187 comm="openconnect" scontext=system_u:system_r:vpnc_t:s0 tcontext=system_u:system_r:vpnc_t:s0 tclass=tun_socket

node=i7.infradead.org type=SYSCALL msg=audit(1276638642.484:113): arch=c000003e syscall=16 success=no exit=-13 a0=5 a1=400454ca a2=7fff51e428d0 a3=1 items=0 ppid=2893 pid=3187 auid=4294967295 uid=490 gid=0 euid=490 suid=490 fsuid=490 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="openconnect" exe="/usr/bin/openconnect" subj=system_u:system_r:vpnc_t:s0 key=(null)

Bizarrely it worked fine when I tried it again a few seconds later.
Comment 1 Daniel Walsh 2010-06-16 13:28:37 EDT
Fixed in selinux-policy-3.7.19-29.fc13
Comment 2 David Woodhouse 2010-06-29 03:48:09 EDT
*** Bug 609000 has been marked as a duplicate of this bug. ***
Comment 3 David Woodhouse 2010-06-29 03:49:51 EDT
Seen in F-12 too...
Comment 4 Bug Zapper 2010-11-03 09:10:55 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-12-03 08:50:56 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.