Bug 609000 - openconnect triggers selinux error
openconnect triggers selinux error
Status: CLOSED DUPLICATE of bug 604443
Product: Fedora
Classification: Fedora
Component: openconnect (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 03:26 EDT by mathieu.lacage
Modified: 2010-06-29 03:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 03:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mathieu.lacage 2010-06-29 03:26:13 EDT
Description of problem:

openconnect succeeds the first time I setup the vpn but triggers a selinux access error on later attempts

Version-Release number of selected component (if applicable):

libselinux-2.0.90-5.fc12
selinux-policy-targeted-3.6.32-118
selinux-policy-3.6.32-118
libselinux-utils-2.0.90-5
openconnect-2.22-1
NetworkManager-openconnect-0.8.0-1.git20100411

How reproducible:

The error appears reproducible only after I setup and shutdown the vpn once. I need to reboot to be able to get it to work again later

Steps to Reproduce:
1. connect to vpn (success)
2. disconnect from vpn
3. connect to vpn
  
Actual results:

network manager reports a vpn connection failure, I get a selinux error popup (copied below). Sometimes, despite the vpn connection failure message, the network manager icon in the toolbar shows a successful connection icon (but the connection really does not work).

Expected results:

Hopefully, the vpn would work all the time.

Additional info:

Summary:

SELinux is preventing /usr/bin/openconnect "relabelfrom" access .

Detailed Description:

[openconnect has a permissive type (vpnc_t). This access was not denied.]

SELinux denied access requested by openconnect. It is not expected that this
access is required by openconnect and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:vpnc_t:s0
Target Context                system_u:system_r:vpnc_t:s0
Target Objects                None [ tun_socket ]
Source                        openconnect
Source Path                   /usr/bin/openconnect
Port                          <Unknown>
Host                          mathieu-laptop
Source RPM Packages           openconnect-2.22-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-118.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     mathieu-laptop
Platform                      Linux mathieu-laptop 2.6.32.14-127.fc12.x86_64 #1
                              SMP Fri May 28 04:30:39 UTC 2010 x86_64 x86_64
Alert Count                   6
First Seen                    Fri 25 Jun 2010 11:49:27 AM CEST
Last Seen                     Tue 29 Jun 2010 09:16:36 AM CEST
Local ID                      ccb311e4-21fe-4352-b076-9913115d76a8
Line Numbers                  

Raw Audit Messages            

node=mathieu-laptop type=AVC msg=audit(1277795796.428:24): avc:  denied  { relabelfrom } for  pid=4361 comm="openconnect" scontext=system_u:system_r:vpnc_t:s0 tcontext=system_u:system_r:vpnc_t:s0 tclass=tun_socket

node=mathieu-laptop type=SYSCALL msg=audit(1277795796.428:24): arch=c000003e syscall=16 success=yes exit=4294967424 a0=5 a1=400454ca a2=7fff1a977f20 a3=20 items=0 ppid=4303 pid=4361 auid=4294967295 uid=490 gid=0 euid=490 suid=490 fsuid=490 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="openconnect" exe="/usr/bin/openconnect" subj=system_u:system_r:vpnc_t:s0 key=(null)
Comment 1 David Woodhouse 2010-06-29 03:48:09 EDT

*** This bug has been marked as a duplicate of bug 604443 ***

Note You need to log in before you can comment on or make changes to this bug.