Bug 60446 - binutils: ld "selective2" fails
binutils: ld "selective2" fails
Status: CLOSED DUPLICATE of bug 60445
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 16:04 EST by Christopher Holmes
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 13:22:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-02-27 16:04:47 EST
Description of Problem:

	binutils: ld "selective2" fails

Version-Release number of selected component (if applicable):

	binutils-2.11.90.0.8-12.src.rpm

How Reproducible:

	always

Steps to Reproduce:

1. rpm -i binutils-2.11.90.0.8-12.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpm -ba binutils.spec
4. cd /usr/src/redhat/BUILD/binutils-2.11.90.0.8
5. make -k check
6. review ./ld/ld.log

Actual Results:

gcc -L/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld -w -O -ffunction-sections
-fdata-sections -B/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/tmpdir/gas/
-I/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective -O2
-mieee  -c
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective/2.c -o
tmpdir/2.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/ld-new  -o tmpdir/2.x
--gc-sections -Bstatic  tmpdir/2.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/../binutils/nm-new  tmpdir/2.x
>tmpdir/nm.out
selective2: foo == 0x00000001200000d0
FAIL: selective2


Expected Results:

PASS: selective2

Additional Information:
	expected results achieved on intel RedHat7.2
Comment 1 Alexandre Petit-Bianco 2002-03-26 15:43:01 EST

*** This bug has been marked as a duplicate of 60445 ***

Note You need to log in before you can comment on or make changes to this bug.