Bug 60445 - binutils: ld "selective1" fails
binutils: ld "selective1" fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
:
: 60446 60447 60448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 16:00 EST by Christopher Holmes
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 13:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-02-27 16:00:08 EST
Description of Problem:

	binutils: ld "selective1" fails

Version-Release number of selected component (if applicable):

	binutils-2.11.90.0.8-12.src.rpm 

How Reproducible:

	always

Steps to Reproduce:

1. rpm -i binutils-2.11.90.0.8-12.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpm -ba binutils.spec
4. cd /usr/src/redhat/BUILD/binutils-2.11.90.0.8
5. make -k check
6. review ./ld/ld.log

Actual Results:

gcc -L/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld -w -O -ffunction-sections
-fdata-sections -B/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/tmpdir/gas/
-I/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective -O2
-mieee  -c
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective/1.c -o
tmpdir/1.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/ld-new  -o tmpdir/1.x
--gc-sections -Bstatic  tmpdir/1.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/../binutils/nm-new  tmpdir/1.x
>tmpdir/nm.out
selective1: dropme1 == 0x00000001200000c0
FAIL: selective1

Expected Results:

PASS: selective1

Additional Information:
	expected results achieved on intel RedHat7.2
Comment 1 Alexandre Petit-Bianco 2002-03-26 15:41:56 EST
Selective linking wasn't implemented on elf64-alpha. The compiler seems to be
doing the right thing, but BFD doesn't provide the necessary support. As a
result, the tests are failing and should probably be turned off for that
particular platform until the implementation is carried out.


Comment 2 Alexandre Petit-Bianco 2002-03-26 15:42:54 EST
*** Bug 60446 has been marked as a duplicate of this bug. ***
Comment 3 Alexandre Petit-Bianco 2002-03-26 15:44:06 EST
*** Bug 60447 has been marked as a duplicate of this bug. ***
Comment 4 Alexandre Petit-Bianco 2002-03-26 15:47:58 EST
*** Bug 60448 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Petit-Bianco 2002-03-27 16:00:48 EST
One more thing. I've been told by one of the binutils maintainer that these 
test cases were now specifically disabled on elf64-alpha.


Comment 6 George France 2002-04-17 17:15:23 EDT
I do not believe that the test should be disabled for alpha.  Maybe marked XFAIL
would be more appropriate????

--George

Note You need to log in before you can comment on or make changes to this bug.