Bug 60447 - binutils: ld "selective4" fails
Summary: binutils: ld "selective4" fails
Status: CLOSED DUPLICATE of bug 60445
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 7.3
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-27 21:07 UTC by Christopher Holmes
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 18:23:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Holmes 2002-02-27 21:07:27 UTC
Description of Problem:

	binutils: ld "selective4" fails

Version-Release number of selected component (if applicable):

	binutils-2.11.90.0.8-12.src.rpm

How Reproducible:

	always

Steps to Reproduce:

1. rpm -i binutils-2.11.90.0.8-12.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpm -ba binutils.spec
4. cd /usr/src/redhat/BUILD/binutils-2.11.90.0.8
5. make -k check
6. review ./ld/ld.log

Actual Results:

gcc -L/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld -w -O -ffunction-sections
-fdata-sections -fvtable-gc -fno-exceptions -fno-rtti
-B/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/tmpdir/gas/
-I/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective -O2
-mieee  -c
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-selective/3.cc -o
tmpdir/3.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/ld-new  -o tmpdir/3.x
--gc-sections -Bstatic  tmpdir/3.o
tmpdir/3.o(.gnu.linkonce.d.__vt_1B+0x8): undefined reference to `__pure_virtual'
tmpdir/3.o(.gnu.linkonce.d.__vt_1A+0x8): undefined reference to `__pure_virtual'
FAIL: selective4


Expected Results:

PASS: selective4

Additional Information:

	expected results achieved on intel RedHat7.2

Comment 1 Alexandre Petit-Bianco 2002-03-26 20:44:11 UTC

*** This bug has been marked as a duplicate of 60445 ***


Note You need to log in before you can comment on or make changes to this bug.